summaryrefslogtreecommitdiff
path: root/src/helper/Makefile.am
diff options
context:
space:
mode:
authoroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-07-22 11:06:09 +0000
committeroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-07-22 11:06:09 +0000
commit7ccfcdea0b51de1cd23694dee1e72682fc6d757d (patch)
treee156c6d56b078fef977c57871938108d14e86cbf /src/helper/Makefile.am
parent6e5416106e8e6305c48f09f810d4535fe7acec3e (diff)
downloadopenocd+libswd-7ccfcdea0b51de1cd23694dee1e72682fc6d757d.tar.gz
openocd+libswd-7ccfcdea0b51de1cd23694dee1e72682fc6d757d.tar.bz2
openocd+libswd-7ccfcdea0b51de1cd23694dee1e72682fc6d757d.tar.xz
openocd+libswd-7ccfcdea0b51de1cd23694dee1e72682fc6d757d.zip
Spen: startup.tcl cross compile support
git-svn-id: svn://svn.berlios.de/openocd/trunk@856 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/helper/Makefile.am')
-rw-r--r--src/helper/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/src/helper/Makefile.am b/src/helper/Makefile.am
index 6e1af8fd..64d051d2 100644
--- a/src/helper/Makefile.am
+++ b/src/helper/Makefile.am
@@ -15,14 +15,12 @@ libhelper_a_SOURCES = binarybuffer.c $(CONFIGFILES) configuration.c log.c comman
noinst_HEADERS = binarybuffer.h configuration.h types.h log.h command.h \
time_support.h replacements.h fileio.h jim.h
+bin2char$(EXEEXT_FOR_BUILD): bin2char.c
+ ${CC_FOR_BUILD} ${CFLAGS_FOR_BUILD} $(srcdir)/bin2char.c -o $@
# Convert .tcl to cfile
-#
-# Fix!!! how do we make this more automake friendly?
-#
-startup_tcl.c: startup.tcl
- gcc -o bin2char $(srcdir)/bin2char.c
- ./bin2char startup_tcl < $(srcdir)/startup.tcl > $@
+startup_tcl.c: startup.tcl bin2char$(EXEEXT_FOR_BUILD)
+ ./bin2char$(EXEEXT_FOR_BUILD) startup_tcl < $(srcdir)/startup.tcl > $@
# add startup_tcl.c to make clean list
-CLEANFILES = startup_tcl.c
+CLEANFILES = startup_tcl.c bin2char$(EXEEXT_FOR_BUILD)