summaryrefslogtreecommitdiff
path: root/src/helper/Makefile.am
diff options
context:
space:
mode:
authorDavid Brownell <dbrownell@users.sourceforge.net>2009-10-16 13:52:40 -0700
committerDavid Brownell <dbrownell@users.sourceforge.net>2009-10-16 13:52:40 -0700
commitcb7965da154793430d935f4965d7360198b711ba (patch)
tree1ca65b04f77e65884b82b80cc490552a347ee31e /src/helper/Makefile.am
parenta61b57a87fec48a41c7429715c477077b545d698 (diff)
downloadopenocd+libswd-cb7965da154793430d935f4965d7360198b711ba.tar.gz
openocd+libswd-cb7965da154793430d935f4965d7360198b711ba.tar.bz2
openocd+libswd-cb7965da154793430d935f4965d7360198b711ba.tar.xz
openocd+libswd-cb7965da154793430d935f4965d7360198b711ba.zip
xscale: better fix for debug_handler.bin
Generate a C struct with the data, and use that, instead of an assembly language file. The assembly language causes issues on Darwin and MS-Windows, which don't necessarily use GNU AS; or if they do, don't necessarily use its ELF syntax. It's also better in two other ways: fewer global symbols; and the init-time size check gets optimized away at compile time. (Unless it fails, in which case bigger chunks of the file vanish.) Signed-off-by: David Brownell <dbrownell@users.sourceforge.net>
Diffstat (limited to 'src/helper/Makefile.am')
-rw-r--r--src/helper/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/helper/Makefile.am b/src/helper/Makefile.am
index 7047253b..67250a18 100644
--- a/src/helper/Makefile.am
+++ b/src/helper/Makefile.am
@@ -52,12 +52,16 @@ noinst_HEADERS = \
startup.tcl \
bin2char.c
-bin2char$(EXEEXT_FOR_BUILD): bin2char.c
+BIN2C = bin2char$(EXEEXT_FOR_BUILD)
+
+BUILT_SOURCES = $(BIN2C)
+
+$(BIN2C): bin2char.c
${CC_FOR_BUILD} ${CFLAGS_FOR_BUILD} $(srcdir)/bin2char.c -o $@
# Convert .tcl to cfile
-startup_tcl.c: startup.tcl bin2char$(EXEEXT_FOR_BUILD)
- ./bin2char$(EXEEXT_FOR_BUILD) startup_tcl < $(srcdir)/startup.tcl > $@
+startup_tcl.c: startup.tcl $(BIN2C)
+ ./$(BIN2C) startup_tcl < $(srcdir)/startup.tcl > $@
# add startup_tcl.c to make clean list
CLEANFILES = startup_tcl.c bin2char$(EXEEXT_FOR_BUILD)