summaryrefslogtreecommitdiff
path: root/src/helper/Makefile.am
diff options
context:
space:
mode:
authorntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-04-21 09:02:42 +0000
committerntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-04-21 09:02:42 +0000
commitdcdf71c21b997550703ab5ac39f5a8f69d3d180d (patch)
treec79a1f2b13de70bce0a28a1f130fc076e4d3ec2f /src/helper/Makefile.am
parent9997362a2a526636f0f165109870e52b0e16a705 (diff)
downloadopenocd+libswd-dcdf71c21b997550703ab5ac39f5a8f69d3d180d.tar.gz
openocd+libswd-dcdf71c21b997550703ab5ac39f5a8f69d3d180d.tar.bz2
openocd+libswd-dcdf71c21b997550703ab5ac39f5a8f69d3d180d.tar.xz
openocd+libswd-dcdf71c21b997550703ab5ac39f5a8f69d3d180d.zip
- fix signed/unsigned build errors under win32. Thanks Zach Welch <zw@superlucidity.net>
git-svn-id: svn://svn.berlios.de/openocd/trunk@1489 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/helper/Makefile.am')
-rw-r--r--src/helper/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/helper/Makefile.am b/src/helper/Makefile.am
index 0cfdf7c3..e8d9a694 100644
--- a/src/helper/Makefile.am
+++ b/src/helper/Makefile.am
@@ -18,6 +18,11 @@ if IOUTIL
libhelper_a_SOURCES += ioutil.c
endif
+libhelper_a_CFLAGS =
+if IS_MINGW
+# FD_* macros are sloppy with their signs on MinGW32 platform
+libhelper_a_CFLAGS += -Wno-sign-compare
+endif
noinst_HEADERS = binarybuffer.h configuration.h types.h log.h command.h \
time_support.h replacements.h fileio.h jim.h jim-eventloop.h \