summaryrefslogtreecommitdiff
path: root/src/interface/Makefile.am
diff options
context:
space:
mode:
authorTomek CEDRO <cederom@tlen.pl>2011-06-16 05:11:26 +0000
committerTomek CEDRO <cederom@tlen.pl>2011-06-16 05:11:26 +0000
commit3bb38c315653476ac92d4eed300e1bd0b58745db (patch)
treea8b0f1205962ddc2b0dbd56704fb714744738d17 /src/interface/Makefile.am
parentc8b57198025c414f8d19577e6846021843c2a751 (diff)
downloadopenocd+libswd-3bb38c315653476ac92d4eed300e1bd0b58745db.tar.gz
openocd+libswd-3bb38c315653476ac92d4eed300e1bd0b58745db.tar.bz2
openocd+libswd-3bb38c315653476ac92d4eed300e1bd0b58745db.tar.xz
openocd+libswd-3bb38c315653476ac92d4eed300e1bd0b58745db.zip
INTERFACE: Adding new place for generic interface driver and routines in src/interface. Adding interface signal definitions and routines. Adding bitbang functionality that works on signals.
Diffstat (limited to 'src/interface/Makefile.am')
-rw-r--r--src/interface/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/interface/Makefile.am b/src/interface/Makefile.am
new file mode 100644
index 00000000..925ec64a
--- /dev/null
+++ b/src/interface/Makefile.am
@@ -0,0 +1,27 @@
+include $(top_srcdir)/common.mk
+
+METASOURCES = AUTO
+noinst_LTLIBRARIES = libinterface.la
+
+SUBDIRS =
+DRIVERFILES =
+libinterface_la_LIBADD =
+
+CLEANFILES =
+
+BUILT_SOURCES =
+
+BUILT_SOURCES +=
+CLEANFILES +=
+
+libinterface_la_SOURCES = \
+ interface.c \
+ bitbang.c
+
+noinst_HEADERS = \
+ interface.h \
+ bitbang.h
+
+EXTRA_DIST =
+
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in