summaryrefslogtreecommitdiff
path: root/src/jtag/Makefile.am
diff options
context:
space:
mode:
authorzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-06-02 23:15:12 +0000
committerzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-06-02 23:15:12 +0000
commita5467296097cc0a820da3aad65dcd9de196fc1be (patch)
tree06fe064c886f05e120a43645e0149179bfb91c9f /src/jtag/Makefile.am
parent7dc29156fee5d4ae30f65f4c82e8cefde763fe40 (diff)
downloadopenocd+libswd-a5467296097cc0a820da3aad65dcd9de196fc1be.tar.gz
openocd+libswd-a5467296097cc0a820da3aad65dcd9de196fc1be.tar.bz2
openocd+libswd-a5467296097cc0a820da3aad65dcd9de196fc1be.tar.xz
openocd+libswd-a5467296097cc0a820da3aad65dcd9de196fc1be.zip
Add header file for JTAG minidriver:
- Wraps all minidriver API functions using API front-ends: - Outlines jtag_add_dr_out() and jtag_alloc_in_value32(). - Adds interface_ prefix to existing jtag_alloc_invalue_32 routines. - Re-inline these interface definitions in new header file. - Re-inline parts of the (mini)driver implementations in minidriver.h. - Replace INCLUDE_JTAG_MINIDRIVER_H with #include directives. The next patch will finish removing '#ifdef HAVE_JTAG_MINIDRIVER_H' from jtag.h. git-svn-id: svn://svn.berlios.de/openocd/trunk@2006 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/jtag/Makefile.am')
-rw-r--r--src/jtag/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/jtag/Makefile.am b/src/jtag/Makefile.am
index c2d98033..1f04f017 100644
--- a/src/jtag/Makefile.am
+++ b/src/jtag/Makefile.am
@@ -136,6 +136,7 @@ libjtag_la_SOURCES = \
$(ARMJTAGEWFILES)
noinst_HEADERS = \
+ minidriver.h \
bitbang.h \
jtag.h \
bitq.h \