summaryrefslogtreecommitdiff
path: root/src/rtos/Makefile.am
diff options
context:
space:
mode:
authorBroadcom Corporation (Evan Hunter) <ehunter@broadcom.com>2011-04-14 10:25:01 +0200
committerØyvind Harboe <oyvind.harboe@zylin.com>2011-04-15 08:24:18 +0200
commitb69119668ed8d9633280f8b596fe9af60f51644b (patch)
tree68a8f525c679f6ce4a9a852b90116afa214329e0 /src/rtos/Makefile.am
parentf9feeacb7fa9b1f60d803708b831bde2187f29b5 (diff)
downloadopenocd+libswd-b69119668ed8d9633280f8b596fe9af60f51644b.tar.gz
openocd+libswd-b69119668ed8d9633280f8b596fe9af60f51644b.tar.bz2
openocd+libswd-b69119668ed8d9633280f8b596fe9af60f51644b.tar.xz
openocd+libswd-b69119668ed8d9633280f8b596fe9af60f51644b.zip
RTOS Thread awareness support wip
- works on Cortex-M3 with ThreadX and FreeRTOS Compared to original patch a few nits were fixed: - remove stricmp usage - unsigned compare fix - printf formatting fixes - fixed a bug with overrunning a memory buffer allocated with malloc.
Diffstat (limited to 'src/rtos/Makefile.am')
-rw-r--r--src/rtos/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/rtos/Makefile.am b/src/rtos/Makefile.am
new file mode 100644
index 00000000..12368d2e
--- /dev/null
+++ b/src/rtos/Makefile.am
@@ -0,0 +1,35 @@
+# ***************************************************************************
+# * Copyright (C) 2011 by Broadcom Corporation *
+# * Evan Hunter - ehunter@broadcom.com *
+# * *
+# * This program is free software; you can redistribute it and/or modify *
+# * it under the terms of the GNU General Public License as published by *
+# * the Free Software Foundation; either version 2 of the License, or *
+# * (at your option) any later version. *
+# * *
+# * This program is distributed in the hope that it will be useful, *
+# * but WITHOUT ANY WARRANTY; without even the implied warranty of *
+# * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the *
+# * GNU General Public License for more details. *
+# * *
+# * You should have received a copy of the GNU General Public License *
+# * along with this program; if not, write to the *
+# * Free Software Foundation, Inc., *
+# * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+# ***************************************************************************
+
+include $(top_srcdir)/common.mk
+
+METASOURCES = AUTO
+noinst_LTLIBRARIES = librtos.la
+noinst_HEADERS = rtos.h
+librtos_la_SOURCES = rtos.c rtos_standard_stackings.c FreeRTOS.c ThreadX.c
+
+
+librtos_la_CFLAGS =
+if IS_MINGW
+# FD_* macros are sloppy with their signs on MinGW32 platform
+librtos_la_CFLAGS += -Wno-sign-compare
+endif
+
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in