summaryrefslogtreecommitdiff
path: root/src/target/Makefile.am
diff options
context:
space:
mode:
authorbodylove <bodylove@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2007-12-10 17:49:28 +0000
committerbodylove <bodylove@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2007-12-10 17:49:28 +0000
commit142a4a4b86685f295739bd19bd9c347a3a1a5439 (patch)
treeecf8b6cd60bbe54ce4d3d5865fa1c8da4277bbc6 /src/target/Makefile.am
parent78d58dd16a276d5a3547d2f681f5062415736c85 (diff)
downloadopenocd+libswd-142a4a4b86685f295739bd19bd9c347a3a1a5439.tar.gz
openocd+libswd-142a4a4b86685f295739bd19bd9c347a3a1a5439.tar.bz2
openocd+libswd-142a4a4b86685f295739bd19bd9c347a3a1a5439.tar.xz
openocd+libswd-142a4a4b86685f295739bd19bd9c347a3a1a5439.zip
- XScale DebugHandler code is now installed into
pkglibdir and loaded from there git-svn-id: svn://svn.berlios.de/openocd/trunk@222 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/target/Makefile.am')
-rw-r--r--src/target/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/target/Makefile.am b/src/target/Makefile.am
index 39486427..5646d90d 100644
--- a/src/target/Makefile.am
+++ b/src/target/Makefile.am
@@ -7,6 +7,7 @@ endif
INCLUDES = -I$(top_srcdir)/src/gdb -I$(top_srcdir)/src/helper -I$(top_srcdir)/src/jtag -I$(top_srcdir)/src/xsvf $(all_includes)
METASOURCES = AUTO
+AM_CPPFLAGS = -DPKGLIBDIR=\"$(pkglibdir)\" @CPPFLAGS@
noinst_LIBRARIES = libtarget.a
libtarget_a_SOURCES = target.c register.c breakpoints.c armv4_5.c embeddedice.c etm.c arm7tdmi.c arm9tdmi.c \
arm_jtag.c arm7_9_common.c algorithm.c arm920t.c arm720t.c armv4_5_mmu.c armv4_5_cache.c arm_disassembler.c \
@@ -16,3 +17,6 @@ noinst_HEADERS = target.h register.h armv4_5.h embeddedice.h etm.h arm7tdmi.h ar
arm_jtag.h arm7_9_common.h arm920t.h arm720t.h armv4_5_mmu.h armv4_5_cache.h breakpoints.h algorithm.h \
arm_disassembler.h arm966e.h arm926ejs.h etb.h xscale.h arm_simulator.h image.h armv7m.h cortex_m3.h cortex_swjdp.h \
etm_dummy.h oocd_trace.h target_request.h trace.h
+
+nobase_pkglib_DATA = xscale/debug_handler.bin
+