summaryrefslogtreecommitdiff
path: root/src/target/Makefile.am
diff options
context:
space:
mode:
authorzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-10 22:03:57 +0000
committerzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-10 22:03:57 +0000
commit647e61cc6d9b13dd2799d2302ce9289a1627e36c (patch)
tree5172bfbe4df60948bf6d61ebea28366a51c03c12 /src/target/Makefile.am
parent104580e0bfb5aa2f79bc6c4c96935a8832f5f787 (diff)
downloadopenocd+libswd-647e61cc6d9b13dd2799d2302ce9289a1627e36c.tar.gz
openocd+libswd-647e61cc6d9b13dd2799d2302ce9289a1627e36c.tar.bz2
openocd+libswd-647e61cc6d9b13dd2799d2302ce9289a1627e36c.tar.xz
openocd+libswd-647e61cc6d9b13dd2799d2302ce9289a1627e36c.zip
Extend autotools build to create shared library libopenocd with libtool:
- Add libtoolize step too bootstrap script; creates ltmain.sh script. - Add AC_PROG_LIBTOOL to configure.in to add libtool support to build. - Change Makefile.am library rules from static (_a) to libtool (_la). - Install libopenocd.{la,so,a} in $(libdir); update openocd link rules. - Extend MAINTAINERCLEANFILES in top-level Makefile.am to remove ltmain.sh. git-svn-id: svn://svn.berlios.de/openocd/trunk@1695 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/target/Makefile.am')
-rw-r--r--src/target/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/target/Makefile.am b/src/target/Makefile.am
index 640ff4a6..90796180 100644
--- a/src/target/Makefile.am
+++ b/src/target/Makefile.am
@@ -11,8 +11,9 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/src/xsvf
METASOURCES = AUTO
-noinst_LIBRARIES = libtarget.a
-libtarget_a_SOURCES = target.c register.c breakpoints.c armv4_5.c embeddedice.c etm.c arm7tdmi.c arm9tdmi.c \
+noinst_LTLIBRARIES = libtarget.la
+libtarget_la_SOURCES = target.c register.c breakpoints.c \
+ armv4_5.c embeddedice.c etm.c arm7tdmi.c arm9tdmi.c \
arm_jtag.c arm7_9_common.c algorithm.c arm920t.c arm720t.c armv4_5_mmu.c armv4_5_cache.c arm_disassembler.c \
arm966e.c arm926ejs.c feroceon.c etb.c xscale.c arm_simulator.c image.c armv7m.c cortex_m3.c cortex_a8.c arm_adi_v5.c \
etm_dummy.c $(OOCD_TRACE_FILES) target_request.c trace.c arm11.c arm11_dbgtap.c mips32.c mips_m4k.c \