summaryrefslogtreecommitdiff
path: root/src/target/Makefile.am
diff options
context:
space:
mode:
authoroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-08-25 06:57:26 +0000
committeroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-08-25 06:57:26 +0000
commit6f7491c1c10844e9e65482980a04182a3547bf4e (patch)
tree306a546617f0bdd0f0288b97c09a95f56eba9680 /src/target/Makefile.am
parent0ed5f5afd95746db72c071a5373981d79cd49c11 (diff)
downloadopenocd+libswd-6f7491c1c10844e9e65482980a04182a3547bf4e.tar.gz
openocd+libswd-6f7491c1c10844e9e65482980a04182a3547bf4e.tar.bz2
openocd+libswd-6f7491c1c10844e9e65482980a04182a3547bf4e.tar.xz
openocd+libswd-6f7491c1c10844e9e65482980a04182a3547bf4e.zip
David Brownell Subset of Cortex-A8 support from Magnus: create an armv7a file
and seed it with DAP access support using the current ADIv5 code. (With tweaks and cleanup from Øyvind and Dave.) The ARMv7-AR architecture manual is not publicly available (even in subset form like the ARMv7-M spec), so it's hard to distinguish between the Cortex-A8 implementation and the ARMv7-A architecture. The register set presumably is architectural, and so it's stored here; it's like earlier ARMs, with small additions. Ditto the instruction set, though Thumb2 support is used (extending Thumb support from ARMv6 with more 32-bit instructions) and there's this ThumbEE thing too. There is a new "debug monitor" mode, not yet fully addressed here, to support debugging in environments (like motor control) where halting debug mode is inadvisable. git-svn-id: svn://svn.berlios.de/openocd/trunk@2608 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/target/Makefile.am')
-rw-r--r--src/target/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/target/Makefile.am b/src/target/Makefile.am
index 807e87e3..05232752 100644
--- a/src/target/Makefile.am
+++ b/src/target/Makefile.am
@@ -38,6 +38,7 @@ libtarget_la_SOURCES = \
arm_simulator.c \
image.c \
armv7m.c \
+ armv7a.c \
cortex_m3.c \
cortex_a8.c \
arm_adi_v5.c \
@@ -80,6 +81,7 @@ noinst_HEADERS = \
arm_simulator.h \
image.h \
armv7m.h \
+ armv7a.h \
cortex_m3.h \
cortex_a8.h \
arm_adi_v5.h \