summaryrefslogtreecommitdiff
path: root/src/target/Makefile.am
diff options
context:
space:
mode:
authorOleksandr Tymoshenko <gonzo@bluezbox.com>2010-08-15 21:51:34 +0200
committerØyvind Harboe <oyvind.harboe@zylin.com>2010-08-15 21:51:34 +0200
commitc3d51bf0da7333de303adf86011913a4bca96e4d (patch)
treebc1afa41a5722ee45bd023943bef9401d4d90af0 /src/target/Makefile.am
parentbb88f3f470b7e3805636983c533756e84806bd2f (diff)
downloadopenocd+libswd-c3d51bf0da7333de303adf86011913a4bca96e4d.tar.gz
openocd+libswd-c3d51bf0da7333de303adf86011913a4bca96e4d.tar.bz2
openocd+libswd-c3d51bf0da7333de303adf86011913a4bca96e4d.tar.xz
openocd+libswd-c3d51bf0da7333de303adf86011913a4bca96e4d.zip
avr32: work-in-progress
committed so as to ease cooperation and to let it be improved over time. So far it supports: - halt/resume - registers inspection - memory inspection/modification I'm still getting up to speed with OpenOCD internals and AVR32 so code is a little bit messy and I'd appreciate any feedback.
Diffstat (limited to 'src/target/Makefile.am')
-rw-r--r--src/target/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/target/Makefile.am b/src/target/Makefile.am
index ea6d88fc..e01e0774 100644
--- a/src/target/Makefile.am
+++ b/src/target/Makefile.am
@@ -32,6 +32,7 @@ libtarget_la_SOURCES = \
$(ARMV6_SRC) \
$(ARMV7_SRC) \
$(ARM_MISC_SRC) \
+ $(AVR32_SRC) \
$(MIPS32_SRC) \
avrt.c \
dsp563xx.c \
@@ -92,6 +93,12 @@ ARM_DEBUG_SRC = \
$(OOCD_TRACE_FILES) \
etm_dummy.c
+AVR32_SRC = \
+ avr32_ap7k.c \
+ avr32_jtag.c \
+ avr32_mem.c \
+ avr32_regs.c
+
MIPS32_SRC = \
mips32.c \
mips_m4k.c \