summaryrefslogtreecommitdiff
path: root/src/target/Makefile.am
diff options
context:
space:
mode:
authorDavid Brownell <dbrownell@users.sourceforge.net>2009-11-24 00:13:58 -0800
committerDavid Brownell <dbrownell@users.sourceforge.net>2009-11-24 00:13:58 -0800
commite6dc927e972bb2d91131b0193b676c531377f318 (patch)
treef8e874a5b1ec5e199dccb44c7f9d0e8452174ea3 /src/target/Makefile.am
parentad75af0b17af75d57b95298fb40784d33cc8f3e2 (diff)
downloadopenocd+libswd-e6dc927e972bb2d91131b0193b676c531377f318.tar.gz
openocd+libswd-e6dc927e972bb2d91131b0193b676c531377f318.tar.bz2
openocd+libswd-e6dc927e972bb2d91131b0193b676c531377f318.tar.xz
openocd+libswd-e6dc927e972bb2d91131b0193b676c531377f318.zip
ARM: new DPM interface
First version of interface for sharing code between ARMv6 and ARMv7a debug modules ... now the architecture includes debug support. (Not the same as for the trimmed-down v7m or v6m though!) This is a first version of an interface that will let the ARM11 and Cortex-A8 support share code, features, and bugfixes. Based on existing code from both of those cores. The ARM v7-AR architecture specification calls this commonality the "Debug Programmer's Model (DPM)", which seemed to be an appropriate acronym -- a TLA even! -- for use in our code. Made it so. :) The initial scope of this just supports register access, and is geared towards supporting top level "struct arm" mechanisms. Later, things like breakpoint and watchpoint support should be included. Signed-off-by: David Brownell <dbrownell@users.sourceforge.net>
Diffstat (limited to 'src/target/Makefile.am')
-rw-r--r--src/target/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/target/Makefile.am b/src/target/Makefile.am
index 23aea82c..a367fd42 100644
--- a/src/target/Makefile.am
+++ b/src/target/Makefile.am
@@ -75,6 +75,7 @@ ARMV7_SRC = \
cortex_a8.c
ARM_DEBUG_SRC = \
+ arm_dpm.c \
arm_jtag.c \
arm_disassembler.c \
arm_simulator.c \
@@ -96,6 +97,7 @@ MIPS32_SRC = \
noinst_HEADERS = \
algorithm.h \
+ arm_dpm.h \
arm_jtag.h \
arm_adi_v5.h \
arm_disassembler.h \