summaryrefslogtreecommitdiff
path: root/src/target/Makefile.am
diff options
context:
space:
mode:
authorNicolas Pitre <nico@fluxnic.net>2009-12-03 17:27:13 -0500
committerDavid Brownell <dbrownell@users.sourceforge.net>2009-12-03 18:42:01 -0800
commited59dfc80aa6fc48a0894c8e46cee675f38ac949 (patch)
tree2f0e0d1f3efb989f5b43f794536cce04bbd3e622 /src/target/Makefile.am
parentf62c035c5277871193fa9904f430cf57221c0b89 (diff)
downloadopenocd+libswd-ed59dfc80aa6fc48a0894c8e46cee675f38ac949.tar.gz
openocd+libswd-ed59dfc80aa6fc48a0894c8e46cee675f38ac949.tar.bz2
openocd+libswd-ed59dfc80aa6fc48a0894c8e46cee675f38ac949.tar.xz
openocd+libswd-ed59dfc80aa6fc48a0894c8e46cee675f38ac949.zip
basic ARM semihosting support
Semihosting enables code running on an ARM target to use the I/O facilities on the host computer. The target application must be linked against a library that forwards operation requests by using the SVC instruction that is trapped at the Supervisor Call vector by the debugger. The "hosted" library version provided with CodeSourcery's Sourcery G++ Lite for ARM EABI is one example. This is currently available for ARM9 processors, but any ARM variant should be able to support this with little additional work. Tested using binaries compiled with Sourcery G++ Lite 2009q1-161 and ARM RVCT 3.0. [dbrownell@users.sourceforge.net: doc tweaks, NEWS] Signed-off-by: Nicolas Pitre <nico@marvell.com> Signed-off-by: David Brownell <dbrownell@users.sourceforge.net>
Diffstat (limited to 'src/target/Makefile.am')
-rw-r--r--src/target/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/target/Makefile.am b/src/target/Makefile.am
index 7631beaa..bd7bf7ae 100644
--- a/src/target/Makefile.am
+++ b/src/target/Makefile.am
@@ -78,6 +78,7 @@ ARM_DEBUG_SRC = \
arm_jtag.c \
arm_disassembler.c \
arm_simulator.c \
+ arm_semihosting.c \
arm_adi_v5.c \
embeddedice.c \
trace.c \
@@ -101,6 +102,7 @@ noinst_HEADERS = \
arm_adi_v5.h \
arm_disassembler.h \
arm_simulator.h \
+ arm_semihosting.h \
arm7_9_common.h \
arm7tdmi.h \
arm720t.h \