summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fae00866..20b64251 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,7 +6,6 @@ else
MAINFILE = main.c jim.c
endif
-
openocd_SOURCES = $(MAINFILE) openocd.c startup.c
# set the include path found by configure
@@ -99,4 +98,7 @@ nobase_dist_pkglib_DATA = \
# Convert .tcl to .c file
startup.c: $(top_srcdir)/src/startup.tcl Makefile $(top_srcdir)/src/file2c.tcl
- tclsh $(top_srcdir)/src/file2c.tcl $(top_srcdir)/src/startup.tcl startup.c \ No newline at end of file
+ ${TCLSH} $(top_srcdir)/src/file2c.tcl $(top_srcdir)/src/startup.tcl startup.c
+
+# add startup.c to make clean list
+CLEANFILES = startup.c