summaryrefslogtreecommitdiff
path: root/src/flash/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/flash/Makefile.am')
-rw-r--r--src/flash/Makefile.am26
1 files changed, 7 insertions, 19 deletions
diff --git a/src/flash/Makefile.am b/src/flash/Makefile.am
index 94cc86e5..353fcf16 100644
--- a/src/flash/Makefile.am
+++ b/src/flash/Makefile.am
@@ -1,3 +1,6 @@
+SUBDIRS = \
+ nand
+
AM_CPPFLAGS = \
-I$(top_srcdir)/src/helper \
-I$(top_srcdir)/src/jtag \
@@ -10,6 +13,9 @@ libflash_la_SOURCES = \
$(NAND_SRCS) \
mflash.c
+libflash_la_LIBADD = \
+ $(top_builddir)/src/flash/nand/libocdflashnand.la
+
FLASH_SRCS = \
common.c \
cfi.c \
@@ -40,22 +46,8 @@ NAND_SRCS = \
arm_nandio.c \
nand_ecc.c \
nand_ecc_kw.c \
- $(NAND_DEVICES_SRCS) \
nand.c
-NAND_DEVICES_SRCS = \
- nonce_nand.c \
- davinci_nand.c \
- lpc3180_nand_controller.c \
- mx3_nand.c \
- orion_nand.c \
- s3c24xx_nand.c \
- s3c2410_nand.c \
- s3c2412_nand.c \
- s3c2440_nand.c \
- s3c2443_nand.c
-
-
noinst_HEADERS = \
arm_nandio.h \
at91sam7.h \
@@ -66,9 +58,7 @@ noinst_HEADERS = \
flash.h \
lpc2000.h \
lpc288x.h \
- lpc3180_nand_controller.h \
mflash.h \
- mx3_nand.h \
non_cfi.h \
nand.h \
ocl.h \
@@ -78,9 +68,7 @@ noinst_HEADERS = \
str7x.h \
str9x.h \
str9xpec.h \
- tms470.h \
- s3c24xx_nand.h \
- s3c24xx_regs_nand.h
+ tms470.h
EXTRA_DIST = startup.tcl