summaryrefslogtreecommitdiff
path: root/src/helper/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/helper/Makefile.am')
-rw-r--r--src/helper/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/helper/Makefile.am b/src/helper/Makefile.am
index e8d9a694..e0686401 100644
--- a/src/helper/Makefile.am
+++ b/src/helper/Makefile.am
@@ -1,6 +1,10 @@
-INCLUDES = -I$(top_srcdir)/src $(all_includes) -I$(top_srcdir)/src/target -I$(top_srcdir)/src/server
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/server \
+ -I$(top_srcdir)/src/target \
+ -DPKGDATADIR=\"$(pkgdatadir)\" \
+ -DPKGLIBDIR=\"$(pkglibdir)\"
+
METASOURCES = AUTO
-AM_CPPFLAGS = -DPKGDATADIR=\"$(pkgdatadir)\" -DPKGLIBDIR=\"$(pkglibdir)\" @CPPFLAGS@
noinst_LIBRARIES = libhelper.a
if ECOSBOARD