summaryrefslogtreecommitdiff
path: root/src/helper/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/helper/Makefile.am')
-rw-r--r--src/helper/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/src/helper/Makefile.am b/src/helper/Makefile.am
index 8a2d472e..2ba0a563 100644
--- a/src/helper/Makefile.am
+++ b/src/helper/Makefile.am
@@ -6,10 +6,24 @@ noinst_LIBRARIES = libhelper.a
if ECOSBOARD
CONFIGFILES =
else
-CONFIGFILES = options.c
+CONFIGFILES = options.c jim.c
endif
libhelper_a_SOURCES = binarybuffer.c $(CONFIGFILES) configuration.c log.c command.c time_support.c \
replacements.c fileio.c
noinst_HEADERS = binarybuffer.h configuration.h types.h log.h command.h \
- time_support.h replacements.h fileio.h
+ time_support.h replacements.h fileio.h \
+ jim.h
+
+libhelper_a_SOURCES += startup_tcl.c
+
+noinst_PROGRAMS = bin2char
+
+bin2char_SOURCES = bin2char.c
+
+# Convert .tcl to cfile
+startup_tcl.c: bin2char startup.tcl
+ ./bin2char startup_tcl < $(srcdir)/startup.tcl > startup_tcl.c
+
+# add startup_tcl.c to make clean list
+CLEANFILES = startup_tcl.c