summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZachary T Welch <zw@superlucidity.net>2009-11-24 08:59:45 -0800
committerZachary T Welch <zw@superlucidity.net>2009-11-24 09:17:52 -0800
commit5507b5f430e3d6bef00a7ffcd51df29c13d7477e (patch)
tree924b0d1c700d15723e3bdb86dfde311e540a3629 /Makefile.am
parent96f0ab894adf606526325cd0b0d0c25413d448b8 (diff)
downloadopenocd_libswd-5507b5f430e3d6bef00a7ffcd51df29c13d7477e.tar.gz
openocd_libswd-5507b5f430e3d6bef00a7ffcd51df29c13d7477e.tar.bz2
openocd_libswd-5507b5f430e3d6bef00a7ffcd51df29c13d7477e.tar.xz
openocd_libswd-5507b5f430e3d6bef00a7ffcd51df29c13d7477e.zip
fix doxygen build
Update build rules to skip the PDF unless the TeX has been created. Also, fixes a warning regarding pattern rules being a GNU make trick.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index c0677120..fab47046 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,9 +35,14 @@ THE_MANUAL = doxygen/latex/refman.pdf
doxygen::
$(MAKE) Doxyfile
doxygen Doxyfile 2>&1 | perl $(srcdir)/tools/logger.pl > doxygen.log
- $(MAKE) $(THE_MANUAL)
-
-%.pdf: %.tex
+ @if [ -f doxygen/latex/refman.tex ]; then \
+ echo "Creating $(THE_MANUAL)..."; \
+ $(MAKE) $(THE_MANUAL); \
+ else \
+ echo "Skipping Doxygen PDF..."; \
+ fi
+
+$(THE_MANUAL): %.pdf: %.tex
-cd $$(dirname $*) && pdflatex $$(basename $*)
-cd $$(dirname $*) && pdflatex $$(basename $*)