summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-12-16 22:20:10 +0000
committeroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-12-16 22:20:10 +0000
commit0fc19255c365a59acf4683d177bacf662e84d4f1 (patch)
tree3040742475f5489e629a5e2185e3ef2f319de232 /configure.in
parent439a187ea146146e9dc008df5c7511d4c13ded5c (diff)
downloadopenocd_libswd-0fc19255c365a59acf4683d177bacf662e84d4f1.tar.gz
openocd_libswd-0fc19255c365a59acf4683d177bacf662e84d4f1.tar.bz2
openocd_libswd-0fc19255c365a59acf4683d177bacf662e84d4f1.tar.xz
openocd_libswd-0fc19255c365a59acf4683d177bacf662e84d4f1.zip
work in progress to hook up libmicrohttpd + tcl integration
git-svn-id: svn://svn.berlios.de/openocd/trunk@1251 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8889db4c..642be2ed 100644
--- a/configure.in
+++ b/configure.in
@@ -71,6 +71,10 @@ AC_ARG_ENABLE(ioutil,
AS_HELP_STRING([--enable-ioutil], [Enable ioutil functions - useful for standalone OpenOCD implementations]),
[build_ioutil=$enableval], [build_ioutil=no])
+AC_ARG_ENABLE(httpd,
+ AS_HELP_STRING([--enable-httpd], [Enable builtin httpd server - useful for standalone OpenOCD implementations]),
+ [build_httpd=$enableval], [build_httpd=no])
+
case "${host_cpu}" in
arm*)
AC_ARG_ENABLE(ep93xx,
@@ -189,6 +193,12 @@ else
AC_DEFINE(BUILD_IOUTIL, 0, [0 if you don't want ioutils.])
fi
+if test $build_httpd = yes; then
+ AC_DEFINE(BUILD_HTTPD, 1, [1 if you want httpd.])
+else
+ AC_DEFINE(BUILD_HTTPD, 0, [0 if you don't want httpd.])
+fi
+
if test $build_at91rm9200 = yes; then
build_bitbang=yes
AC_DEFINE(BUILD_AT91RM9200, 1, [1 if you want at91rm9200.])
@@ -285,6 +295,7 @@ AM_CONDITIONAL(GIVEIO, test $parport_use_giveio = yes)
AM_CONDITIONAL(EP93XX, test $build_ep93xx = yes)
AM_CONDITIONAL(ECOSBOARD, test $build_ecosboard = yes)
AM_CONDITIONAL(IOUTIL, test $build_ioutil = yes)
+AM_CONDITIONAL(HTTPD, test $build_httpd = yes)
AM_CONDITIONAL(AT91RM9200, test $build_at91rm9200 = yes)
AM_CONDITIONAL(BITBANG, test $build_bitbang = yes)
AM_CONDITIONAL(FT2232_LIBFTDI, test $build_ft2232_libftdi = yes)