summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorLiam Redmond <info@rock-software.com>2009-11-12 12:50:41 -0800
committerDavid Brownell <dbrownell@users.sourceforge.net>2009-11-12 12:50:41 -0800
commit26849ad60d269b0e8d254882bc75268a393dd2a1 (patch)
tree743913dfb29f923f910f4a691ea6b67763a0ca73 /configure.in
parentde735d375b979377e124dc2daf1a5f473de19d81 (diff)
downloadopenocd_libswd-26849ad60d269b0e8d254882bc75268a393dd2a1.tar.gz
openocd_libswd-26849ad60d269b0e8d254882bc75268a393dd2a1.tar.bz2
openocd_libswd-26849ad60d269b0e8d254882bc75268a393dd2a1.tar.xz
openocd_libswd-26849ad60d269b0e8d254882bc75268a393dd2a1.zip
WinXP-x64: find right D2XX libraries
This trivial patch allows the config script to find the correct FTDI2xx libraries under Windows XP x64 using msys. Signed-off-by: David Brownell <dbrownell@users.sourceforge.net>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d7f8d476..fa2a4985 100644
--- a/configure.in
+++ b/configure.in
@@ -736,12 +736,12 @@ if test $build_ft2232_ftd2xx = yes -o $build_presto_ftd2xx = yes ; then
# And calculate the LDFLAGS for the machine
case "$host_cpu" in
- i?86|x86_*)
+ i?86|x86_32)
LDFLAGS="$LDFLAGS -L$with_ftd2xx_win32_zipdir/i386"
LIBS="$LIBS -lftd2xx"
f=$with_ftd2xx_win32_zipdir/i386/ftd2xx.lib
;;
- amd64)
+ amd64|x86_64)
LDFLAGS="$LDFLAGS -L$with_ftd2xx_win32_zipdir/amd64"
LIBS="$LIBS -lftd2xx"
f=$with_ftd2xx_win32_zipdir/amd64/ftd2xx.lib