summaryrefslogtreecommitdiff
path: root/src/jtag/Makefile.am
diff options
context:
space:
mode:
authorZachary T Welch <zw@superlucidity.net>2009-11-19 12:02:07 -0800
committerZachary T Welch <zw@superlucidity.net>2009-11-24 07:30:19 -0800
commit3a660e229301c905392a0b2826e5ebf08c4e01b9 (patch)
treed8d14d934592a41c75f3996c745846b066001b7e /src/jtag/Makefile.am
parent3efc99b34a934cb4d657ec27a164769c46c10f28 (diff)
downloadopenocd_libswd-3a660e229301c905392a0b2826e5ebf08c4e01b9.tar.gz
openocd_libswd-3a660e229301c905392a0b2826e5ebf08c4e01b9.tar.bz2
openocd_libswd-3a660e229301c905392a0b2826e5ebf08c4e01b9.tar.xz
openocd_libswd-3a660e229301c905392a0b2826e5ebf08c4e01b9.zip
add jtag/usb_common.[ch] files
Begins to consolidate code used by several USB JTAG interfaces. This first patch provides the required build system changes and a common jtag_usb_open routine, which will replace the guts for probing the busses and devices for possible VID/PID matches. The following patches convert each driver to use it.
Diffstat (limited to 'src/jtag/Makefile.am')
-rw-r--r--src/jtag/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/jtag/Makefile.am b/src/jtag/Makefile.am
index 85d98c07..5254a2b5 100644
--- a/src/jtag/Makefile.am
+++ b/src/jtag/Makefile.am
@@ -23,6 +23,10 @@ else
# Standard Driver: common files
DRIVERFILES += driver.c commands.c
+if USB
+DRIVERFILES += usb_common.c
+endif
+
if BITBANG
DRIVERFILES += bitbang.c
endif
@@ -92,7 +96,8 @@ noinst_HEADERS = \
rlink/ep1_cmd.h \
rlink/rlink.h \
rlink/st7.h \
- minidummy/jtag_minidriver.h
+ minidummy/jtag_minidriver.h \
+ usb_common.h
EXTRA_DIST = startup.tcl