summaryrefslogtreecommitdiff
path: root/src/jtag/Makefile.am
diff options
context:
space:
mode:
authorDavid Brownell <dbrownell@users.sourceforge.net>2010-07-02 16:45:28 -0400
committerDavid Brownell <db@helium.(none)>2010-07-02 16:45:28 -0400
commit93f2afa45f4cfcb8afd08dae5a17996dba5c7a9c (patch)
tree0c03935bd09e77c5edd98e1b356f0ffbc3df239b /src/jtag/Makefile.am
parentdeb176d33514eb6b702b14043c338b2d0053f11d (diff)
downloadopenocd_libswd-93f2afa45f4cfcb8afd08dae5a17996dba5c7a9c.tar.gz
openocd_libswd-93f2afa45f4cfcb8afd08dae5a17996dba5c7a9c.tar.bz2
openocd_libswd-93f2afa45f4cfcb8afd08dae5a17996dba5c7a9c.tar.xz
openocd_libswd-93f2afa45f4cfcb8afd08dae5a17996dba5c7a9c.zip
initial "transport" framework
This adds the guts of a transport framework with initialization, which should work with current JTAG-only configurations (tested with FT2232). Each debug adapter can declare the transports it supports, and exactly one transport is initialized. (with its commands) in any given OpenOCD session. * Define a new "struct transport with init hooks and a few "transport" subcommands to support it: "list" ... list the transports configured (just "jtag" for now) "select" ... makes the debug session use that transport "init" ... initializes the selected transport (internal) * "interface_transports" ... declares transports the current interface can support. (Some will do this from C code instead, when there are no hardware versioning (or other) issues to prevent it. Plus some FT2232 tweaks, including a few to streamline upcoming support for an SWD transport (initially for Luminary adapters). Eventually src/jtag should probably become src/transport, moving jtag-specific stuff to transport/jtag. Signed-off-by: David Brownell <db@helium.(none)>
Diffstat (limited to 'src/jtag/Makefile.am')
-rw-r--r--src/jtag/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/jtag/Makefile.am b/src/jtag/Makefile.am
index 910affc1..59cd8fff 100644
--- a/src/jtag/Makefile.am
+++ b/src/jtag/Makefile.am
@@ -58,6 +58,7 @@ libjtag_la_SOURCES = \
interface.c \
interfaces.c \
tcl.c \
+ transport.c \
$(DRIVERFILES)
noinst_HEADERS = \
@@ -67,6 +68,7 @@ noinst_HEADERS = \
interfaces.h \
minidriver.h \
jtag.h \
+ transport.h \
minidriver/minidriver_imp.h \
minidummy/jtag_minidriver.h