summaryrefslogtreecommitdiff
path: root/src/jtag/Makefile.am
diff options
context:
space:
mode:
authorzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-06-29 00:00:50 +0000
committerzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-06-29 00:00:50 +0000
commitc2cecc74b0acb11254392b6622655a4758f35903 (patch)
tree33899eae8db9d6de426270433b7b4039e9dba8ed /src/jtag/Makefile.am
parent445fef39fbc06eb1d3d9669c91e792561dcf922a (diff)
downloadopenocd_libswd-c2cecc74b0acb11254392b6622655a4758f35903.tar.gz
openocd_libswd-c2cecc74b0acb11254392b6622655a4758f35903.tar.bz2
openocd_libswd-c2cecc74b0acb11254392b6622655a4758f35903.tar.xz
openocd_libswd-c2cecc74b0acb11254392b6622655a4758f35903.zip
Move JTAG interface list to new files.
- Adds new source files to encapsulate static/dynamic module handling. - Further work should implement the jtag_interface_modules_load routine, to populate the jtag_interfaces list from shared libraries in a path. git-svn-id: svn://svn.berlios.de/openocd/trunk@2413 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/jtag/Makefile.am')
-rw-r--r--src/jtag/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/jtag/Makefile.am b/src/jtag/Makefile.am
index 5af6c74f..ba722c6d 100644
--- a/src/jtag/Makefile.am
+++ b/src/jtag/Makefile.am
@@ -75,12 +75,14 @@ endif
libjtag_la_SOURCES = \
core.c \
- tcl.c \
interface.c \
+ interfaces.c \
+ tcl.c \
$(DRIVERFILES)
noinst_HEADERS = \
interface.h \
+ interfaces.h \
commands.h \
minidriver.h \
bitbang.h \