summaryrefslogtreecommitdiff
path: root/src/jtag/Makefile.am
diff options
context:
space:
mode:
authorzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-06-08 00:42:15 +0000
committerzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-06-08 00:42:15 +0000
commitf84c78a2e1994ef8efcdd8768dc2a6b0ee363189 (patch)
treecc5813f7f0b91036fcdc1f465562ce476b4d20c8 /src/jtag/Makefile.am
parentb770ad5b194c57b2ce69e2940943123bda33d992 (diff)
downloadopenocd_libswd-f84c78a2e1994ef8efcdd8768dc2a6b0ee363189.tar.gz
openocd_libswd-f84c78a2e1994ef8efcdd8768dc2a6b0ee363189.tar.bz2
openocd_libswd-f84c78a2e1994ef8efcdd8768dc2a6b0ee363189.tar.xz
openocd_libswd-f84c78a2e1994ef8efcdd8768dc2a6b0ee363189.zip
Finish off the dummy minidriver integration:
- Try to disambiguates minidriver options from "standard" driver options. - Make minidummy symbols more explict about being a minidriver. - Move minidummy.c into minidummy directory to put it with its header. In configure.in: - Improve configuration option to allow new minidriver implementations: - Change option from --enable-minidummy to --enable-minidriver-dummy. - Move it to the end of the list of options. - Provides a clear pattern for future minidrivers. - Update handling of HAVE_JTAG_MINIDRIVER_H: - Check for external jtag_minidriver.h only with --enable-ecosboard. - Otherwise, define it when --enable-minidriver-dummy is provided. - Add check to ensure only one minidriver is enabled. - When a minidriver is enabled, warn user that standard drivers are not built. - Use proper AC_DEFINE semantics with MINIDRIVER_DUMMY. In src/jtag/Makefile.am: - Restructure handling of minidummy source files. - Include minidummy driver header in the distribution. In src/jtag/jtag.c: - Restructure preprocessor logic to include: - only one minidriver, or - all configured standard drivers. git-svn-id: svn://svn.berlios.de/openocd/trunk@2102 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/jtag/Makefile.am')
-rw-r--r--src/jtag/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/jtag/Makefile.am b/src/jtag/Makefile.am
index fa5861a5..6be4db04 100644
--- a/src/jtag/Makefile.am
+++ b/src/jtag/Makefile.am
@@ -51,14 +51,15 @@ else
ECOSBOARDFILES =
endif
-if MINIDUMMY
-MINIDUMMYFILES = minidummy.c
+if MINIDRIVER_DUMMY
+MINIDUMMYFILES = minidummy.c commands.c
+AM_CPPFLAGS += -I$(srcdir)/minidummy
else
MINIDUMMYFILES =
endif
if MINIDRIVER
-DRIVERFILES =
+DRIVERFILES = $(MINIDUMMYFILES)
else
DRIVERFILES = jtag_driver.c commands.c
endif
@@ -137,7 +138,6 @@ libjtag_la_SOURCES = \
$(PRESTOFILES) \
$(USBPROGFILES) \
$(ECOSBOARDFILES) \
- $(MINIDUMMYFILES) \
$(JLINKFILES) \
$(RLINKFILES) \
$(VSLLINKFILES) \
@@ -153,6 +153,7 @@ noinst_HEADERS = \
rlink/dtc_cmd.h \
rlink/ep1_cmd.h \
rlink/rlink.h \
- rlink/st7.h
+ rlink/st7.h \
+ minidummy/jtag_minidriver.h
MAINTAINERCLEANFILES = Makefile.in