summaryrefslogtreecommitdiff
path: root/src/target/Makefile.am
diff options
context:
space:
mode:
authordrath <drath@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2006-06-12 16:49:49 +0000
committerdrath <drath@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2006-06-12 16:49:49 +0000
commitb9628accd6da0aef6a9fc03efb96e05afab99c99 (patch)
tree91006cc62c3ca10641efbe41a6829ed16671cf10 /src/target/Makefile.am
parent335f667d4433e8ca3a57e813fd128b78d8b364d2 (diff)
downloadopenocd_libswd-b9628accd6da0aef6a9fc03efb96e05afab99c99.tar.gz
openocd_libswd-b9628accd6da0aef6a9fc03efb96e05afab99c99.tar.bz2
openocd_libswd-b9628accd6da0aef6a9fc03efb96e05afab99c99.tar.xz
openocd_libswd-b9628accd6da0aef6a9fc03efb96e05afab99c99.zip
- the 'help' command now takes an optional argument to display help only on a certain command (thanks to Andrew Dyer for this enhancement)
- OpenOCD now includes the ability to diassemble instructions on its own (only ARM for now, Thumb might follow). The command is "armv4_5 disassemble <address> <count> ['thumb']" (thumb is currently unsupported). I've compared the produced disassembly against GDB/GNU Objdump output, and it seems to be correct, but there may still be some bugs left. git-svn-id: svn://svn.berlios.de/openocd/trunk@68 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/target/Makefile.am')
-rw-r--r--src/target/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/target/Makefile.am b/src/target/Makefile.am
index 7e26762b..2192469c 100644
--- a/src/target/Makefile.am
+++ b/src/target/Makefile.am
@@ -2,6 +2,7 @@ INCLUDES = -I$(top_srcdir)/src/gdb -I$(top_srcdir)/src/helper -I$(top_srcdir)/s
METASOURCES = AUTO
noinst_LIBRARIES = libtarget.a
libtarget_a_SOURCES = target.c register.c breakpoints.c armv4_5.c embeddedice.c etm.c arm7tdmi.c arm9tdmi.c \
- arm_jtag.c arm7_9_common.c algorithm.c arm920t.c arm720t.c armv4_5_mmu.c armv4_5_cache.c
+ arm_jtag.c arm7_9_common.c algorithm.c arm920t.c arm720t.c armv4_5_mmu.c armv4_5_cache.c arm_disassembler.c
noinst_HEADERS = target.h register.h armv4_5.h embeddedice.h etm.h arm7tdmi.h arm9tdmi.h \
- arm_jtag.h arm7_9_common.h arm920t.h arm720t.h armv4_5_mmu.h armv4_5_cache.h breakpoints.h algorithm.h
+ arm_jtag.h arm7_9_common.h arm920t.h arm720t.h armv4_5_mmu.h armv4_5_cache.h breakpoints.h algorithm.h \
+ arm_disassembler.h