summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-08-31 18:18:01 +0000
committerRichard Purdie <richard@openedhand.com>2005-08-31 18:18:01 +0000
commit962491ebe2df3563ea8e9b6803949c98c387a134 (patch)
treef28e1924a555a591fbac9509083e52b2e48db6e1
parent9ed0d2aa99a76a864d4793f54146c0e79e373712 (diff)
downloadopenembedded-core-962491ebe2df3563ea8e9b6803949c98c387a134.tar.gz
openembedded-core-962491ebe2df3563ea8e9b6803949c98c387a134.tar.bz2
openembedded-core-962491ebe2df3563ea8e9b6803949c98c387a134.tar.xz
openembedded-core-962491ebe2df3563ea8e9b6803949c98c387a134.zip
Add x11-common
git-svn-id: https://svn.o-hand.com/repos/poky@11 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--openembedded/packages/meta/meta-oh.bb3
-rw-r--r--openembedded/packages/meta/oh-image.bb2
-rw-r--r--openembedded/packages/xcalibrate/xcalibrate_cvs.bb20
-rw-r--r--openembedded/packages/xdpyinfo/xdpyinfo_cvs.bb12
-rw-r--r--openembedded/packages/xmodmap/xmodmap/autofoo.patch109
-rw-r--r--openembedded/packages/xmodmap/xmodmap_cvs.bb14
-rw-r--r--openembedded/packages/xtscal/xtscal/xtscal-cxk.patch11
-rw-r--r--openembedded/packages/xtscal/xtscal/xtscal-poodle.patch12
-rw-r--r--openembedded/packages/xtscal/xtscal_0.6.3.bb13
-rw-r--r--openembedded/packages/xtst/xtst_cvs.bb21
10 files changed, 215 insertions, 2 deletions
diff --git a/openembedded/packages/meta/meta-oh.bb b/openembedded/packages/meta/meta-oh.bb
index 450afc207..179ba17b8 100644
--- a/openembedded/packages/meta/meta-oh.bb
+++ b/openembedded/packages/meta/meta-oh.bb
@@ -2,7 +2,7 @@ PACKAGES = "oh-base-depends oh-task-base"
# oh-task-base
DESCRIPTION = "Meta-package for OpenHand Palmtop Environment"
MAINTAINER = "Richard Purdie <richard@openedhand.com>"
-PR = "r1"
+PR = "r2"
ALLOW_EMPTY = "1"
@@ -16,6 +16,7 @@ DEPENDS += " ${oh-base-depends}"
oh-task-base = "\
matchbox \
xcursor-transparent-theme \
+ x11-common \
rxvt \
xhost \
ttf-bitstream-vera \
diff --git a/openembedded/packages/meta/oh-image.bb b/openembedded/packages/meta/oh-image.bb
index 27042725f..91ca5e56e 100644
--- a/openembedded/packages/meta/oh-image.bb
+++ b/openembedded/packages/meta/oh-image.bb
@@ -1,4 +1,4 @@
-PR = "r1"
+PR = "r2"
export IMAGE_BASENAME = "oh-image"
diff --git a/openembedded/packages/xcalibrate/xcalibrate_cvs.bb b/openembedded/packages/xcalibrate/xcalibrate_cvs.bb
new file mode 100644
index 000000000..5436bf26b
--- /dev/null
+++ b/openembedded/packages/xcalibrate/xcalibrate_cvs.bb
@@ -0,0 +1,20 @@
+PV = "0.0cvs${CVSDATE}"
+LICENSE = "BSD-X"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@freedesktop.org>"
+DEPENDS = "x11 xcalibrateext xext"
+DESCRIPTION = "XCalibrate client-side library"
+
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=XCalibrate"
+S = "${WORKDIR}/XCalibrate"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR}
+}
diff --git a/openembedded/packages/xdpyinfo/xdpyinfo_cvs.bb b/openembedded/packages/xdpyinfo/xdpyinfo_cvs.bb
new file mode 100644
index 000000000..6a72d61a7
--- /dev/null
+++ b/openembedded/packages/xdpyinfo/xdpyinfo_cvs.bb
@@ -0,0 +1,12 @@
+PV = "0.0cvs${CVSDATE}"
+LICENSE = "MIT"
+DEPENDS = "x11 xext xtst"
+DESCRIPTION = "X display information utility"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+SECTION = "x11/base"
+PR = "r1"
+
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xapps;module=xdpyinfo"
+S = "${WORKDIR}/xdpyinfo"
+
+inherit autotools pkgconfig
diff --git a/openembedded/packages/xmodmap/xmodmap/autofoo.patch b/openembedded/packages/xmodmap/xmodmap/autofoo.patch
new file mode 100644
index 000000000..f309add08
--- /dev/null
+++ b/openembedded/packages/xmodmap/xmodmap/autofoo.patch
@@ -0,0 +1,109 @@
+diff -urN xmodmap.orig/Makefile.am xmodmap/Makefile.am
+--- xmodmap.orig/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ xmodmap/Makefile.am 2004-08-31 19:49:33.000000000 +0200
+@@ -0,0 +1,53 @@
++#
++# $Id: Makefile.am,v 1.2 2004/06/25 19:38:50 markh Exp $
++#
++# Copyright © 2003 Keith Packard
++#
++# Permission to use, copy, modify, distribute, and sell this software and its
++# documentation for any purpose is hereby granted without fee, provided that
++# the above copyright notice appear in all copies and that both that
++# copyright notice and this permission notice appear in supporting
++# documentation, and that the name of Keith Packard not be used in
++# advertising or publicity pertaining to distribution of the software without
++# specific, written prior permission. Keith Packard makes no
++# representations about the suitability of this software for any purpose. It
++# is provided "as is" without express or implied warranty.
++#
++# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
++# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
++# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
++# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
++# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
++# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
++# PERFORMANCE OF THIS SOFTWARE.
++#
++
++AUTOMAKE_OPTIONS = 1.7 foreign
++
++AM_CFLAGS = @XMODMAP_CFLAGS@
++
++bin_PROGRAMS = xmodmap
++
++xmodmap_SOURCES = exec.c handle.c pf.c wq.h xmodmap.c xmodmap.h
++
++xmodmap_LDADD = @XMODMAP_LIBS@
++
++man5_MANS=xmodmap.man
++
++EXTRA_DIST= $(man5_MANS)
++
++MAINTAINERCLEANFILES = configure \
++config.guess \
++config.sub \
++install-sh \
++ltmain.sh \
++missing \
++mkinstalldirs \
++aclocal.m4 \
++Makefile.in \
++depcomp \
++autoscan.log \
++configure.scan \
++config.h \
++config.h.in \
++$(man5_MANS)
+diff -urN xmodmap.orig/autogen.sh xmodmap/autogen.sh
+--- xmodmap.orig/autogen.sh 1970-01-01 01:00:00.000000000 +0100
++++ xmodmap/autogen.sh 2004-08-31 19:46:14.000000000 +0200
+@@ -0,0 +1,3 @@
++#! /bin/sh
++autoreconf -v --install || exit 1
++./configure --enable-maintainer-mode "$@"
+diff -urN xmodmap.orig/configure.ac xmodmap/configure.ac
+--- xmodmap.orig/configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ xmodmap/configure.ac 2004-08-31 20:27:03.000000000 +0200
+@@ -0,0 +1,41 @@
++dnl
++dnl $Id: configure.ac,v 1.1 2003/10/09 06:16:59 keithp Exp $
++dnl
++dnl Copyright © 2003 Keith Packard
++dnl
++dnl Permission to use, copy, modify, distribute, and sell this software and its
++dnl documentation for any purpose is hereby granted without fee, provided that
++dnl the above copyright notice appear in all copies and that both that
++dnl copyright notice and this permission notice appear in supporting
++dnl documentation, and that the name of Keith Packard not be used in
++dnl advertising or publicity pertaining to distribution of the software without
++dnl specific, written prior permission. Keith Packard makes no
++dnl representations about the suitability of this software for any purpose. It
++dnl is provided "as is" without express or implied warranty.
++dnl
++dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
++dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
++dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
++dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
++dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
++dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
++dnl PERFORMANCE OF THIS SOFTWARE.
++dnl
++
++AC_PREREQ(2.57)
++AC_INIT([xmodmap],4.4.0,[],xmodmap)
++AC_CONFIG_SRCDIR([Makefile.am])
++AM_INIT_AUTOMAKE([dist-bzip2])
++AM_MAINTAINER_MODE
++AM_CONFIG_HEADER(config.h)
++
++AC_PROG_CC
++AC_PROG_INSTALL
++AC_PROG_LN_S
++AC_LIBTOOL_WIN32_DLL
++AM_PROG_LIBTOOL
++AC_PROG_MAKE_SET
++
++PKG_CHECK_MODULES(XMODMAP, x11)
++
++AC_OUTPUT([Makefile])
diff --git a/openembedded/packages/xmodmap/xmodmap_cvs.bb b/openembedded/packages/xmodmap/xmodmap_cvs.bb
new file mode 100644
index 000000000..890e70d95
--- /dev/null
+++ b/openembedded/packages/xmodmap/xmodmap_cvs.bb
@@ -0,0 +1,14 @@
+PV = "0.0cvs${CVSDATE}"
+LICENSE = "MIT"
+DESCRIPTION = "utility for modifying keymaps and pointer button mappings in X"
+MAINTAINER = "Rene Wagner <rw@handhelds.org>"
+SECTION = "x11/base"
+PR = "r1"
+
+DEPENDS = "x11"
+
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xorg;module=xc/programs/xmodmap \
+ file://autofoo.patch;patch=1"
+S = "${WORKDIR}/xmodmap"
+
+inherit autotools pkgconfig
diff --git a/openembedded/packages/xtscal/xtscal/xtscal-cxk.patch b/openembedded/packages/xtscal/xtscal/xtscal-cxk.patch
new file mode 100644
index 000000000..1cab8efb5
--- /dev/null
+++ b/openembedded/packages/xtscal/xtscal/xtscal-cxk.patch
@@ -0,0 +1,11 @@
+--- xtscal-0.6.3/xtscal.in~ 2004-09-10 12:10:36.000000000 -0700
++++ xtscal-0.6.3/xtscal.in 2005-08-04 09:26:46.000000000 -0700
+@@ -8,7 +8,7 @@
+ case `module_id` in
+ "HP IPAQ H3100" | "HP IPAQ H3800" )
+ ARGS="-rotate 90" ;;
+- "HP IPAQ H3600" | "HP IPAQ H3700" | "HP IPAQ H3900" | *COLLIE | *POODLE)
++ "HP IPAQ H3600" | "HP IPAQ H3700" | "HP IPAQ H3900" | *COLLIE | *POODLE | *SPITZ | *AKITA | *BORZOI)
+ ARGS="-rotate 270" ;;
+ # H2200: works without rotation
+ esac
diff --git a/openembedded/packages/xtscal/xtscal/xtscal-poodle.patch b/openembedded/packages/xtscal/xtscal/xtscal-poodle.patch
new file mode 100644
index 000000000..f9a165169
--- /dev/null
+++ b/openembedded/packages/xtscal/xtscal/xtscal-poodle.patch
@@ -0,0 +1,12 @@
+diff -urN xtscal-0.5.1.orig/xtscal.in xtscal-0.5.1/xtscal.in
+--- xtscal-0.5.1.orig/xtscal.in 2004-06-13 07:59:37.000000000 -0400
++++ xtscal-0.5.1/xtscal.in 2004-09-08 20:24:10.000000000 -0400
+@@ -8,7 +8,7 @@
+ case `module_id` in
+ "HP IPAQ H3100" | "HP IPAQ H3800" )
+ ARGS="-rotate 90" ;;
+- "HP IPAQ H3600" | "HP IPAQ H3700" | "HP IPAQ H3900" | *COLLIE)
++ "HP IPAQ H3600" | "HP IPAQ H3700" | "HP IPAQ H3900" | *COLLIE | *POODLE)
+ ARGS="-rotate 270" ;;
+ # H2200: works without rotation
+ esac
diff --git a/openembedded/packages/xtscal/xtscal_0.6.3.bb b/openembedded/packages/xtscal/xtscal_0.6.3.bb
new file mode 100644
index 000000000..a2a770f4f
--- /dev/null
+++ b/openembedded/packages/xtscal/xtscal_0.6.3.bb
@@ -0,0 +1,13 @@
+LICENSE = "GPL"
+DESCRIPTION = "Touchscreen calibration utility"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+SECTION = "x11/base"
+
+DEPENDS = "x11 libxft libxrandr xcalibrate"
+
+PR = "r1"
+
+SRC_URI = "${GPE_MIRROR}/xtscal-${PV}.tar.bz2 \
+ file://xtscal-cxk.patch;patch=1"
+
+inherit autotools
diff --git a/openembedded/packages/xtst/xtst_cvs.bb b/openembedded/packages/xtst/xtst_cvs.bb
new file mode 100644
index 000000000..29119dfe8
--- /dev/null
+++ b/openembedded/packages/xtst/xtst_cvs.bb
@@ -0,0 +1,21 @@
+LICENSE = "GPL"
+PV = "0.0cvs${CVSDATE}"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+DEPENDS = "x11 recordext xext"
+DESCRIPTION = "X Test Extension: client side library"
+PR = "r3"
+
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=Xtst"
+S = "${WORKDIR}/Xtst"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR}
+}