summaryrefslogtreecommitdiff
path: root/meta-moblin/packages
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-07-08 16:19:21 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-07-08 16:19:21 +0100
commit303b0915f733fac29515603aeb034ff4af9099ed (patch)
treebb60c55c224bcda8461c72cd6e66cdb2b628a10c /meta-moblin/packages
parent7649c9d82a063aba157a1978de557fd86f88dd94 (diff)
downloadopenembedded-core-303b0915f733fac29515603aeb034ff4af9099ed.tar.gz
openembedded-core-303b0915f733fac29515603aeb034ff4af9099ed.tar.bz2
openembedded-core-303b0915f733fac29515603aeb034ff4af9099ed.tar.xz
openembedded-core-303b0915f733fac29515603aeb034ff4af9099ed.zip
mutter-moblin: Update after metacity -> mutter rename
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-moblin/packages')
-rw-r--r--meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook/session4
-rw-r--r--meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb57
2 files changed, 53 insertions, 8 deletions
diff --git a/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook/session b/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook/session
index 5cf9ee1bf..79cf1af65 100644
--- a/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook/session
+++ b/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook/session
@@ -1,5 +1,5 @@
#!/bin/sh
export LIBGL_ALWAYS_INDIRECT=1
-
-exec metacity --mutter-plugins=moblin-netbook
+#--mutter-plugins=moblin-netbook
+exec /usr/bin/mutter
diff --git a/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb b/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb
index 518e2d790..a35dd8f87 100644
--- a/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb
+++ b/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Custom MB session files for poky"
LICENSE = "GPL"
SECTION = "x11"
RDEPENDS = "formfactor gtk-engines initscripts matchbox-session"
-PR = "r16"
+PR = "r17"
# This package is architecture specific because the session script is modified
# based on the machine architecture.
@@ -25,6 +25,7 @@ fi
. ${sysconfdir}/init.d/functions
+
# Theme
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
@@ -62,6 +63,25 @@ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
/desktop/gnome/sound/theme_name moblin
+# Screen shot
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type string -s \
+ /apps/metacity/global_keybindings/run_command_screenshot \
+ "Print"
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type string -s \
+ /apps/metacity/keybinding_commands/command_screenshot \
+ "gnome-screenshot"
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type string -s \
+ /apps/metacity/global_keybindings/run_command_window_screenshot \
+ "<Alt>Print"
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type string -s \
+ /apps/metacity/keybinding_commands/command_window_screenshot \
+ "gnome-screenshot --window"
+
# Window Actions
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
@@ -73,14 +93,15 @@ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
/apps/metacity/general/action_right_click_titlebar "none"
+
# UX Shell
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type bool -s \
- /apps/metacity/general/clutter_disabled false
+ /apps/mutter/general/clutter_disabled false
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type list --list-type string -s \
- /apps/metacity/general/clutter_plugins '[moblin-netbook]'
+ /apps/mutter/general/clutter_plugins '[moblin-netbook]'
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
@@ -93,7 +114,7 @@ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
/desktop/gnome/background/picture_filename \
- '/usr/share/mutter-moblin/theme/myzone/toys.jpg'
+ '/usr/share/mutter-moblin/theme/moblin-panel-myzone/toys.jpg'
# Fonts
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
@@ -118,16 +139,40 @@ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type bool -s \
- /apps/nautilus/icon_view/labels_beside_icons true
+ /apps/nautilus/preferences/exit_with_last_window false
+
+# Do not automount, this is done by g-s-d plugin
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type bool -s \
+ /apps/nautilus/preferences/media_automount false
+
+# And should not open new window whenever media mounted
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type bool -s \
+ /apps/nautilus/preferences/media_automount_open false
+
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type bool -s \
+ /apps/nautilus/icon_view/labels_beside_icons false
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
- /apps/nautilus/icon_view/default_zoom_level large
+ /apps/nautilus/icon_view/default_zoom_level standard
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
/apps/gnome_settings_daemon/keybindings/power ""
+# General
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type float -s \
+ /desktop/gnome/peripherals/mouse/mouse_acceleration 0.8
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type int -s \
+ /desktop/gnome/peripherals/mouse/mouse_threshold 2
+
#
# The interesting bit - we convert to run the system as the user "pokyuser"
# and setup this user account as needed