summaryrefslogtreecommitdiff
path: root/meta/packages/bluez/bluez4_4.66.bb
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-06-26 16:07:32 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-30 13:18:44 +0100
commit74221a49871978a8f9f4d6303efb014d2a58825f (patch)
treef006a84f405e01b6df907fcf1c3fa3ef49ca7252 /meta/packages/bluez/bluez4_4.66.bb
parenta5af9cfb4c9da5590335d4e1df88c61aaf7dcb12 (diff)
downloadopenembedded-core-74221a49871978a8f9f4d6303efb014d2a58825f.tar.gz
openembedded-core-74221a49871978a8f9f4d6303efb014d2a58825f.tar.bz2
openembedded-core-74221a49871978a8f9f4d6303efb014d2a58825f.tar.xz
openembedded-core-74221a49871978a8f9f4d6303efb014d2a58825f.zip
bluez4_4.66.bb: Fix recipe metadata
Fix LICENSE information Add HOMEPAGE and LIC_FILES_CHKSUM Adjust variables order according to styleguide Use blank space to replace tab Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/packages/bluez/bluez4_4.66.bb')
-rw-r--r--meta/packages/bluez/bluez4_4.66.bb20
1 files changed, 12 insertions, 8 deletions
diff --git a/meta/packages/bluez/bluez4_4.66.bb b/meta/packages/bluez/bluez4_4.66.bb
index 59193c2f9..644393869 100644
--- a/meta/packages/bluez/bluez4_4.66.bb
+++ b/meta/packages/bluez/bluez4_4.66.bb
@@ -1,9 +1,13 @@
DESCRIPTION = "Linux Bluetooth Stack Userland V4"
+HOMEPAGE = "http://www.bluez.org"
SECTION = "libs"
PRIORITY = "optional"
-DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
-HOMEPAGE = "http://www.bluez.org"
-LICENSE = "GPL"
+LICENSE = "GPLv2+ & LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
+ file://COPYING.LIB;md5=fb504b67c50331fc78734fed90fb0e09 \
+ file://src/main.c;beginline=1;endline=24;md5=9bc54b93cd7e17bf03f52513f39f926e \
+ file://sbc/sbc.c;beginline=1;endline=25;md5=1a40781ed30d50d8639323a184aeb191"
+DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib libnl"
# For angstrom we want this to replace at least bluez-libs
PROVIDES_append_angstrom = " bluez-utils bluez-libs"
@@ -44,11 +48,11 @@ EXTRA_OECONF = "\
"
do_install_append() {
- install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
- install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
- install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
- # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
- install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
+ install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
+ install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
+ install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
+ # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
+ install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
}
PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"