summaryrefslogtreecommitdiff
path: root/meta/packages/libtool/libtool-nativesdk_2.2.10.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-07-09 04:11:46 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-09 23:15:53 +0100
commit9b7907fae23151f250d0584f21d43bfd93fda9ad (patch)
tree80ea94096baf149a6b3bd9c1c835dd93f770b051 /meta/packages/libtool/libtool-nativesdk_2.2.10.bb
parent4e80041a4f3c9bce4ad0c2e17b3400afd4cf4185 (diff)
downloadopenembedded-core-9b7907fae23151f250d0584f21d43bfd93fda9ad.tar.gz
openembedded-core-9b7907fae23151f250d0584f21d43bfd93fda9ad.tar.bz2
openembedded-core-9b7907fae23151f250d0584f21d43bfd93fda9ad.tar.xz
openembedded-core-9b7907fae23151f250d0584f21d43bfd93fda9ad.zip
libtool family: fix build failure caused by previous libtool commit.
prefix.patch was removed from the target libtool recipe. But still part of it is needed to build the man pages. So split the patch into two. One for just fixing the man page building issue. Also tweaked the install of libtool-nativesdk recipe as per prefix patch changes. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/packages/libtool/libtool-nativesdk_2.2.10.bb')
-rw-r--r--meta/packages/libtool/libtool-nativesdk_2.2.10.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/packages/libtool/libtool-nativesdk_2.2.10.bb b/meta/packages/libtool/libtool-nativesdk_2.2.10.bb
index db72dd922..c9f24a95b 100644
--- a/meta/packages/libtool/libtool-nativesdk_2.2.10.bb
+++ b/meta/packages/libtool/libtool-nativesdk_2.2.10.bb
@@ -1,8 +1,8 @@
require libtool_${PV}.bb
PR = "r0"
-SRC_URI_append = " file://cross_compile.patch"
-SRC_URI_append = " file://prefix.patch "
+SRC_URI_append = " file://cross_compile.patch \
+ file://prefix.patch "
inherit nativesdk
@@ -16,12 +16,12 @@ do_configure_prepend () {
do_install () {
autotools_do_install
install -d ${D}${bindir}/
- install -m 0755 libtool ${D}${bindir}/
+ install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/
}
SYSROOT_PREPROCESS_FUNCS += "libtoolnativesdk_sysroot_preprocess"
libtoolnativesdk_sysroot_preprocess () {
install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
- install -m 755 ${D}${bindir}/libtool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool
+ install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool
}