summaryrefslogtreecommitdiff
path: root/meta/packages/libtool/libtool-nativesdk_2.2.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libtool/libtool-nativesdk_2.2.10.bb')
-rw-r--r--meta/packages/libtool/libtool-nativesdk_2.2.10.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/packages/libtool/libtool-nativesdk_2.2.10.bb b/meta/packages/libtool/libtool-nativesdk_2.2.10.bb
index db72dd922..c9f24a95b 100644
--- a/meta/packages/libtool/libtool-nativesdk_2.2.10.bb
+++ b/meta/packages/libtool/libtool-nativesdk_2.2.10.bb
@@ -1,8 +1,8 @@
require libtool_${PV}.bb
PR = "r0"
-SRC_URI_append = " file://cross_compile.patch"
-SRC_URI_append = " file://prefix.patch "
+SRC_URI_append = " file://cross_compile.patch \
+ file://prefix.patch "
inherit nativesdk
@@ -16,12 +16,12 @@ do_configure_prepend () {
do_install () {
autotools_do_install
install -d ${D}${bindir}/
- install -m 0755 libtool ${D}${bindir}/
+ install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/
}
SYSROOT_PREPROCESS_FUNCS += "libtoolnativesdk_sysroot_preprocess"
libtoolnativesdk_sysroot_preprocess () {
install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
- install -m 755 ${D}${bindir}/libtool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool
+ install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool
}