summaryrefslogtreecommitdiff
path: root/meta/packages/matchbox-sato
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-04-09 10:32:10 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-04-09 10:32:10 +0000
commitc9ecfc0f2ec2438df7bd0a20d6d8b1a6acdd6af7 (patch)
treee10b957679b070e493046746304a3ef65aaf1b2f /meta/packages/matchbox-sato
parentac82765a4b5cbab72ec5b8de4e1ae9354dc389c3 (diff)
downloadopenembedded-core-c9ecfc0f2ec2438df7bd0a20d6d8b1a6acdd6af7.tar.gz
openembedded-core-c9ecfc0f2ec2438df7bd0a20d6d8b1a6acdd6af7.tar.bz2
openembedded-core-c9ecfc0f2ec2438df7bd0a20d6d8b1a6acdd6af7.tar.xz
openembedded-core-c9ecfc0f2ec2438df7bd0a20d6d8b1a6acdd6af7.zip
matchbox-session-sato: start Sato components
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4216 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/matchbox-sato')
-rw-r--r--meta/packages/matchbox-sato/matchbox-sato/matchbox-session24
-rw-r--r--[-rwxr-xr-x]meta/packages/matchbox-sato/matchbox-session-sato/session (renamed from meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session)0
-rw-r--r--meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb (renamed from meta/packages/matchbox-sato/matchbox-sato_0.1.bb)24
3 files changed, 6 insertions, 42 deletions
diff --git a/meta/packages/matchbox-sato/matchbox-sato/matchbox-session b/meta/packages/matchbox-sato/matchbox-sato/matchbox-session
deleted file mode 100644
index 4d6caa0c5..000000000
--- a/meta/packages/matchbox-sato/matchbox-sato/matchbox-session
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-#
-# Very simple session manager for matchbox tools
-#
-
-# Uncomment below to enable parsing of debian menu entrys
-# export MB_USE_DEB_MENUS=1
-
-if [ -e $HOME/.matchbox/session ]
-then
-exec $HOME/.matchbox/session
-fi
-
-if [ -e /etc/matchbox/session ]
-then
-exec /etc/matchbox/session
-fi
-
-# Default files to run if $HOME/.matchbox/session or /etc/matchbox/session
-# dont exist.
-
-matchbox-desktop &
-matchbox-panel &
-exec matchbox-window-manager $@
diff --git a/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session b/meta/packages/matchbox-sato/matchbox-session-sato/session
index 010772a8c..010772a8c 100755..100644
--- a/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
+++ b/meta/packages/matchbox-sato/matchbox-session-sato/session
diff --git a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb b/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb
index b8d6d7151..e1180ad30 100644
--- a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
+++ b/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb
@@ -1,27 +1,15 @@
DESCRIPTION = "Custom MB session files for poky"
LICENSE = "GPL"
SECTION = "x11"
-RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts"
-RCONFLICTS = "matchbox-common"
-PR = "r21"
+RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts matchbox-session"
+PR = "r22"
-SRC_URI = "file://etc file://matchbox-session"
-S = ${WORKDIR}
-
-inherit update-alternatives
-
-ALTERNATIVE_NAME = "x-session-manager"
-ALTERNATIVE_LINK = "${bindir}/x-session-manager"
-ALTERNATIVE_PATH = "${bindir}/matchbox-session"
-ALTERNATIVE_PRIORITY = "10"
+SRC_URI = "file://session"
+S = "${WORKDIR}"
do_install() {
- install -d ${D}/${bindir}
- install -m 0755 ${S}/matchbox-session ${D}/${bindir}
- cp -R ${S}/etc ${D}/etc
- rm -fR ${D}/etc/.svn
- rm -fR ${D}/etc/matchbox/.svn
- chmod -R 755 ${D}/etc
+ install -d ${D}/${sysconfdir}/matchbox
+ install -m 0755 ${S}/session ${D}/${sysconfdir}/matchbox/
}
pkg_postinst_matchbox-sato () {