summaryrefslogtreecommitdiff
path: root/meta/packages/mozilla-headless/mozilla-headless_hg.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-14 15:01:07 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-14 15:01:07 +0100
commite6d96312f5d8d78de3874233b6fa9a891d1a5a76 (patch)
tree35d054e021a9b2924e529661ac4d8f4bbcafff59 /meta/packages/mozilla-headless/mozilla-headless_hg.bb
parent59bb17f5c492e2f3e32df8e1a29b4cb8fddb4b05 (diff)
downloadopenembedded-core-e6d96312f5d8d78de3874233b6fa9a891d1a5a76.tar.gz
openembedded-core-e6d96312f5d8d78de3874233b6fa9a891d1a5a76.tar.bz2
openembedded-core-e6d96312f5d8d78de3874233b6fa9a891d1a5a76.tar.xz
openembedded-core-e6d96312f5d8d78de3874233b6fa9a891d1a5a76.zip
mozilla-headless: Convert to hg and add mozilla-headless-services
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/mozilla-headless/mozilla-headless_hg.bb')
-rw-r--r--meta/packages/mozilla-headless/mozilla-headless_hg.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/packages/mozilla-headless/mozilla-headless_hg.bb b/meta/packages/mozilla-headless/mozilla-headless_hg.bb
new file mode 100644
index 000000000..e3ef60b78
--- /dev/null
+++ b/meta/packages/mozilla-headless/mozilla-headless_hg.bb
@@ -0,0 +1,49 @@
+
+SRC_URI = "hg://hg.mozilla.org/incubator;protocol=http;rev=71b4ab01cbf2;module=offscreen \
+ file://configurefix.patch;patch=1 \
+ file://jsautocfg.h \
+ file://mozconfig"
+PV = "0.0+hg-1.0+71b4ab01cbf2"
+PR = "r0"
+
+S = "${WORKDIR}/offscreen"
+
+DEPENDS = "gconf gnome-vfs pango dbus-glib alsa-lib libidl-native sqlite3 libidl"
+
+FILES_${PN} += "${libdir}/xulrunner-1.9.2a1pre"
+FILES_${PN}-dev += "${libdir}/xulrunner-devel-1.9.2a1pre"
+FILES_${PN}-dbg += "${libdir}/xulrunner-devel-1.9.2a1pre/sdk/lib/.debug"
+
+inherit autotools_stage mozilla
+
+acpaths = "-I ${S}/build/autoconf "
+
+export topsrcdir = "${S}"
+
+do_configure () {
+ cp ${S}/build/autoconf/install-sh ${S}
+ autotools_do_configure
+ # Yes, we run this twice. The first pass sets up npsrpub-config which then
+ # sets the values correctly on the second try. Ick.
+ autotools_do_configure
+}
+
+do_compile () {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+ #oe_runmake -f client.mk build_all
+ base_do_compile
+}
+
+EXTRA_OECONF =+ "--enable-application=xulrunner --enable-default-toolkit=cairo-headless --enable-pango --disable-optimize --enable-debug --disable-tests --disable-printing --disable-crashreporter --disable-accessibility --disable-javaxpcom --enable-plugins --enable-system-sqlite --disable-necko-wifi"
+
+export LIBXUL_DIST="${S}/dist"
+
+do_stage_append () {
+ autotools_stage_dir ${STAGE_TEMP}/${libdir}/xulrunner-1.9.2a1pre ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-1.9.2a1pre/
+ autotools_stage_dir ${STAGE_TEMP}/${libdir}/xulrunner-devel-1.9.2a1pre ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/
+ ln -fs ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-1.9.2a1pre/ /media/build2/builds/poky/build1/moblin/staging/i586-poky-linux/usr/lib/xulrunner-devel-1.9.2a1pre/bin
+ ln -fs ${STAGING_DIR_HOST}${layout_datadir}/xulrunner-1.9.2a1pre/unstable/ /media/build2/builds/poky/build1/moblin/staging/i586-poky-linux/usr/lib/xulrunner-devel-1.9.2a1pre/idl
+ ln -fs ${STAGING_DIR_HOST}${layout_includedir}/xulrunner-1.9.2a1pre/unstable/ /media/build2/builds/poky/build1/moblin/staging/i586-poky-linux/usr/lib/xulrunner-devel-1.9.2a1pre/include
+ ln -fs ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/sdk/lib/ /media/build2/builds/poky/build1/moblin/staging/i586-poky-linux/usr/lib/xulrunner-devel-1.9.2a1pre/lib
+}
+