summaryrefslogtreecommitdiff
path: root/meta/packages/oprofile
diff options
context:
space:
mode:
authorRobert Bradford <rob@openedhand.com>2007-02-27 17:56:16 +0000
committerRobert Bradford <rob@openedhand.com>2007-02-27 17:56:16 +0000
commit6a596808c50982ca6db8ced6ce2bc7ad5b92dcc1 (patch)
tree3661864afb8c953cde5cd0808c2bc98f795dd8a9 /meta/packages/oprofile
parent237c2a23adad07210b59ba7b69329b7a908e4fd0 (diff)
downloadopenembedded-core-6a596808c50982ca6db8ced6ce2bc7ad5b92dcc1.tar.gz
openembedded-core-6a596808c50982ca6db8ced6ce2bc7ad5b92dcc1.tar.bz2
openembedded-core-6a596808c50982ca6db8ced6ce2bc7ad5b92dcc1.tar.xz
openembedded-core-6a596808c50982ca6db8ced6ce2bc7ad5b92dcc1.zip
Add a patch to oparchive so that the program exits with non-zero exit code on
error. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1295 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/oprofile')
-rw-r--r--meta/packages/oprofile/oprofile/oparchive-exit-code-on-error.patch11
-rw-r--r--meta/packages/oprofile/oprofile_cvs.bb1
2 files changed, 12 insertions, 0 deletions
diff --git a/meta/packages/oprofile/oprofile/oparchive-exit-code-on-error.patch b/meta/packages/oprofile/oprofile/oparchive-exit-code-on-error.patch
new file mode 100644
index 000000000..ab4d7f421
--- /dev/null
+++ b/meta/packages/oprofile/oprofile/oparchive-exit-code-on-error.patch
@@ -0,0 +1,11 @@
+Index: oprofile/pp/oparchive.cpp
+===================================================================
+--- oprofile.orig/pp/oparchive.cpp 2007-02-27 18:15:52.000000000 +0000
++++ oprofile/pp/oparchive.cpp 2007-02-27 18:16:08.000000000 +0000
+@@ -164,5 +164,5 @@
+
+ int main(int argc, char const * argv[])
+ {
+- run_pp_tool(argc, argv, oparchive);
++ return run_pp_tool(argc, argv, oparchive);
+ }
diff --git a/meta/packages/oprofile/oprofile_cvs.bb b/meta/packages/oprofile/oprofile_cvs.bb
index 034ea51ff..4c4570981 100644
--- a/meta/packages/oprofile/oprofile_cvs.bb
+++ b/meta/packages/oprofile/oprofile_cvs.bb
@@ -12,6 +12,7 @@ SRC_URI = "cvs://anonymous@oprofile.cvs.sourceforge.net/cvsroot/oprofile;module=
file://oparchive-list-files.patch;patch=1 \
file://opreport-xml-output-fixes.patch;patch=1 \
file://xml_callgraph.patch;patch=1 \
+ file://oparchive-exit-code-on-error.patch;patch=1 \
file://acinclude.m4"
S = "${WORKDIR}/oprofile"