summaryrefslogtreecommitdiff
path: root/meta/packages/pciutils/pciutils-2.2.4/configure.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-06-29 07:34:11 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-06-29 07:34:11 +0000
commitf8ca66bdb7fff028d9826b79afb9265f235735f2 (patch)
treebbf5e45cd4b4ce8a3ac7754891ae69e7fcd41379 /meta/packages/pciutils/pciutils-2.2.4/configure.patch
parentba9dd5228c290c96c622fb82964e49ce2511a1e9 (diff)
downloadopenembedded-core-f8ca66bdb7fff028d9826b79afb9265f235735f2.tar.gz
openembedded-core-f8ca66bdb7fff028d9826b79afb9265f235735f2.tar.bz2
openembedded-core-f8ca66bdb7fff028d9826b79afb9265f235735f2.tar.xz
openembedded-core-f8ca66bdb7fff028d9826b79afb9265f235735f2.zip
pciutils: added 2.2.4 from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2054 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/pciutils/pciutils-2.2.4/configure.patch')
-rw-r--r--meta/packages/pciutils/pciutils-2.2.4/configure.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/packages/pciutils/pciutils-2.2.4/configure.patch b/meta/packages/pciutils/pciutils-2.2.4/configure.patch
new file mode 100644
index 000000000..78d113c49
--- /dev/null
+++ b/meta/packages/pciutils/pciutils-2.2.4/configure.patch
@@ -0,0 +1,40 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+Index: pciutils-2.2.4/lib/configure
+===================================================================
+--- pciutils-2.2.4.orig/lib/configure 2006-09-09 13:06:10.000000000 +0200
++++ pciutils-2.2.4/lib/configure 2006-10-31 11:52:13.000000000 +0100
+@@ -12,15 +12,15 @@
+ echo_n "Configuring libpci for your system..."
+ idsdir=${1:-/usr/share}
+ version=${2:-0.0}
+-sys=`uname -s`
+-rel=`uname -r`
++sys=${3:-`uname -s`}
++rel=${4:-`uname -r`}
+ if [ "$sys" = "AIX" -a -x /usr/bin/oslevel -a -x /usr/sbin/lsattr ]
+ then
+ rel=`/usr/bin/oslevel`
+ proc=`/usr/sbin/lsdev -C -c processor -S available -F name | head -1`
+ cpu=`/usr/sbin/lsattr -F value -l $proc -a type | sed 's/_.*//'`
+ else
+- cpu=`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/'`
++ cpu=${5:-`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/'`}
+ fi
+ if [ "$sys" = "GNU/kFreeBSD" ]
+ then
+@@ -34,6 +34,11 @@
+ echo " $host $rel"
+ zlib=$5
+
++if [ "$host" = "linux--gnueabi" ]
++then
++ sys=linux
++fi
++
+ c=config.h
+ m=config.mk
+ echo >$c "#define PCI_ARCH_`echo $cpu | tr 'a-z' 'A-Z'`"