summaryrefslogtreecommitdiff
path: root/meta/packages/pciutils/pciutils-2.2.4/configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/pciutils/pciutils-2.2.4/configure.patch')
-rw-r--r--meta/packages/pciutils/pciutils-2.2.4/configure.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/packages/pciutils/pciutils-2.2.4/configure.patch b/meta/packages/pciutils/pciutils-2.2.4/configure.patch
new file mode 100644
index 000000000..78d113c49
--- /dev/null
+++ b/meta/packages/pciutils/pciutils-2.2.4/configure.patch
@@ -0,0 +1,40 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+Index: pciutils-2.2.4/lib/configure
+===================================================================
+--- pciutils-2.2.4.orig/lib/configure 2006-09-09 13:06:10.000000000 +0200
++++ pciutils-2.2.4/lib/configure 2006-10-31 11:52:13.000000000 +0100
+@@ -12,15 +12,15 @@
+ echo_n "Configuring libpci for your system..."
+ idsdir=${1:-/usr/share}
+ version=${2:-0.0}
+-sys=`uname -s`
+-rel=`uname -r`
++sys=${3:-`uname -s`}
++rel=${4:-`uname -r`}
+ if [ "$sys" = "AIX" -a -x /usr/bin/oslevel -a -x /usr/sbin/lsattr ]
+ then
+ rel=`/usr/bin/oslevel`
+ proc=`/usr/sbin/lsdev -C -c processor -S available -F name | head -1`
+ cpu=`/usr/sbin/lsattr -F value -l $proc -a type | sed 's/_.*//'`
+ else
+- cpu=`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/'`
++ cpu=${5:-`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/'`}
+ fi
+ if [ "$sys" = "GNU/kFreeBSD" ]
+ then
+@@ -34,6 +34,11 @@
+ echo " $host $rel"
+ zlib=$5
+
++if [ "$host" = "linux--gnueabi" ]
++then
++ sys=linux
++fi
++
+ c=config.h
+ m=config.mk
+ echo >$c "#define PCI_ARCH_`echo $cpu | tr 'a-z' 'A-Z'`"