summaryrefslogtreecommitdiff
path: root/meta/packages/telepathy
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-04-24 11:32:02 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-04-24 11:32:02 +0000
commitcfd5c04245ee5ceb055e0a2a59ce4d017a84d4c1 (patch)
tree2918df14af0c3609db492f5f50d8aa62751122de /meta/packages/telepathy
parent59a3ba404f64893f35f17e8a0ac182fc49ccbdb3 (diff)
downloadopenembedded-core-cfd5c04245ee5ceb055e0a2a59ce4d017a84d4c1.tar.gz
openembedded-core-cfd5c04245ee5ceb055e0a2a59ce4d017a84d4c1.tar.bz2
openembedded-core-cfd5c04245ee5ceb055e0a2a59ce4d017a84d4c1.tar.xz
openembedded-core-cfd5c04245ee5ceb055e0a2a59ce4d017a84d4c1.zip
telepathy-glib: added 0.5.10
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1539 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/telepathy')
-rw-r--r--meta/packages/telepathy/telepathy-glib_0.5.10.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/packages/telepathy/telepathy-glib_0.5.10.bb b/meta/packages/telepathy/telepathy-glib_0.5.10.bb
new file mode 100644
index 000000000..f6b6a6c6b
--- /dev/null
+++ b/meta/packages/telepathy/telepathy-glib_0.5.10.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Telepathy framework - GLib library"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus python-native dbus-native"
+LICENSE = "LGPL"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-glib/${P}.tar.gz "
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
+
+do_stage() {
+ #
+ # copied autotools_stage_all because telepathy-glib has one lib only built as static
+ # so it can not be oe_libinstalled
+ #
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ oe_runmake DESTDIR="${STAGE_TEMP}" install
+ if [ -d ${STAGE_TEMP}/${includedir} ]; then
+ cp -fpPR ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
+ fi
+ if [ -d ${STAGE_TEMP}/${libdir} ]
+ then
+ for i in ${STAGE_TEMP}/${libdir}/*.la
+ do
+ if [ ! -f "$i" ]; then
+ cp -fpPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
+ break
+ fi
+ done
+ oe_libinstall -so -C telepathy-glib/.libs libtelepathy-glib ${STAGING_LIBDIR}
+ fi
+ if [ -d ${STAGE_TEMP}/${datadir}/aclocal ]; then
+ install -d ${STAGING_DATADIR}/aclocal
+ cp -fpPR ${STAGE_TEMP}/${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal
+ fi
+ rm -rf ${STAGE_TEMP}
+}