summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-08-03 14:27:47 +0000
committerRichard Purdie <richard@openedhand.com>2007-08-03 14:27:47 +0000
commit09bd1175b2c11a5184668c3584ab3ec8b65a6e51 (patch)
tree810da4254f1c7df035e93208a755da4f54f0b11d /meta/packages
parentbfb0f08271816fe173e2eeba5542b5864fbb1018 (diff)
downloadopenembedded-core-09bd1175b2c11a5184668c3584ab3ec8b65a6e51.tar.gz
openembedded-core-09bd1175b2c11a5184668c3584ab3ec8b65a6e51.tar.bz2
openembedded-core-09bd1175b2c11a5184668c3584ab3ec8b65a6e51.tar.xz
openembedded-core-09bd1175b2c11a5184668c3584ab3ec8b65a6e51.zip
git-native: Add 1.5.2.3
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2348 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/git/git-native_1.5.2.3.bb3
-rw-r--r--meta/packages/git/git.inc15
2 files changed, 18 insertions, 0 deletions
diff --git a/meta/packages/git/git-native_1.5.2.3.bb b/meta/packages/git/git-native_1.5.2.3.bb
new file mode 100644
index 000000000..f91fd03ab
--- /dev/null
+++ b/meta/packages/git/git-native_1.5.2.3.bb
@@ -0,0 +1,3 @@
+require git.inc
+inherit native
+DEPENDS = "openssl-native curl-native"
diff --git a/meta/packages/git/git.inc b/meta/packages/git/git.inc
new file mode 100644
index 000000000..384dfaaee
--- /dev/null
+++ b/meta/packages/git/git.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "The git revision control system used by the Linux kernel developers"
+SECTION = "console/utils"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2"
+S = "${WORKDIR}/git-${PV}"
+
+do_install () {
+ oe_runmake install prefix=${D} bindir=${D}${bindir} \
+ template_dir=${D}${datadir}/git-core/templates \
+ GIT_PYTHON_DIR=${D}${datadir}/git-core/python
+}
+
+FILES_${PN} += "${datadir}/git-core"
+