summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorYu Ke <ke.yu@intel.com>2010-07-27 16:05:29 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-30 14:50:30 +0100
commit16877ce14b9c6b813267e9b1cbf904ccf7b86292 (patch)
tree78f603922456c06f55be10e491da8abbba7ceba1 /meta/packages
parentae035f151f87a9a1ff48ceac10cff45754c21027 (diff)
downloadopenembedded-core-16877ce14b9c6b813267e9b1cbf904ccf7b86292.tar.gz
openembedded-core-16877ce14b9c6b813267e9b1cbf904ccf7b86292.tar.bz2
openembedded-core-16877ce14b9c6b813267e9b1cbf904ccf7b86292.tar.xz
openembedded-core-16877ce14b9c6b813267e9b1cbf904ccf7b86292.zip
avahi: fix the /var/run conflict with other package
avahi will create an empty /var/run dir, which will conflict with base-files package. This patch fix this by using populate-volatiles.sh approach recommended by OE handbook. Signed-off-by: Yu Ke <ke.yu@intel.com>
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/avahi/avahi.inc9
-rw-r--r--meta/packages/avahi/avahi_0.6.27.bb2
2 files changed, 10 insertions, 1 deletions
diff --git a/meta/packages/avahi/avahi.inc b/meta/packages/avahi/avahi.inc
index 4e2949319..2a5bf4a18 100644
--- a/meta/packages/avahi/avahi.inc
+++ b/meta/packages/avahi/avahi.inc
@@ -64,6 +64,15 @@ INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
+do_install() {
+ autotools_do_install
+
+ # don't install /var/run when populating rootfs. Do it through volatile
+ # /var/run of current version is empty, so just remove it.
+ # if /var/run become non-empty in the future, need to install it via volatile
+ rm -rf ${D}/var/run
+}
+
# At the time the postinst runs, dbus might not be setup so only restart if running
pkg_postinst_avahi-daemon () {
diff --git a/meta/packages/avahi/avahi_0.6.27.bb b/meta/packages/avahi/avahi_0.6.27.bb
index 736c61582..a4c22a8b0 100644
--- a/meta/packages/avahi/avahi_0.6.27.bb
+++ b/meta/packages/avahi/avahi_0.6.27.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
file://avahi-client/client.h;endline=23;md5=f4ac741a25c4f434039ba3e18c8674cf"
RDEPENDS_avahi-daemon = "sysvinit-pidof"
-PR = "r0"
+PR = "r1"
EXTRA_OECONF += "--disable-gtk3"