summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-04-12 21:35:14 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-26 14:48:50 +0100
commit11cbd871e0969931d5c81ec53684446f4293faf1 (patch)
tree8a5d7d41ee7b8689da5882ea77395dc2c9337770 /meta/recipes-devtools
parentfe32e09ccbef3a9896955e8d4c3113c53f95de48 (diff)
downloadopenembedded-core-11cbd871e0969931d5c81ec53684446f4293faf1.tar.gz
openembedded-core-11cbd871e0969931d5c81ec53684446f4293faf1.tar.bz2
openembedded-core-11cbd871e0969931d5c81ec53684446f4293faf1.tar.xz
openembedded-core-11cbd871e0969931d5c81ec53684446f4293faf1.zip
gcc-4.7: Do not use --with-header option for cross-gcc
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/gcc/gcc-configure-cross.inc2
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross_4.7.bb6
2 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-configure-cross.inc b/meta/recipes-devtools/gcc/gcc-configure-cross.inc
index 65e340a0d..3cb3452e6 100644
--- a/meta/recipes-devtools/gcc/gcc-configure-cross.inc
+++ b/meta/recipes-devtools/gcc/gcc-configure-cross.inc
@@ -3,12 +3,12 @@ require gcc-configure-common.inc
USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}'
EXTRA_OECONF += " --enable-poison-system-directories \
- --with-headers=${STAGING_DIR_TARGET}${SYSTEMHEADERS} \
"
INHIBIT_DEFAULT_DEPS = "1"
EXTRA_OECONF_PATHS = " \
+ --with-headers=${STAGING_DIR_TARGET}${SYSTEMHEADERS} \
--with-gxx-include-dir=${STAGING_DIR_TARGET}${target_includedir}/c++ \
--with-sysroot=${STAGING_DIR_TARGET} \
--with-build-sysroot=${STAGING_DIR_TARGET}"
diff --git a/meta/recipes-devtools/gcc/gcc-cross_4.7.bb b/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
index 75679d1b0..d60523513 100644
--- a/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
+++ b/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
@@ -5,4 +5,10 @@ EXTRA_OECONF += "--disable-libunwind-exceptions \
--with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
--with-system-zlib "
+EXTRA_OECONF_PATHS = " \
+ --with-gxx-include-dir=${STAGING_DIR_TARGET}${target_includedir}/c++ \
+ --with-sysroot=${STAGING_DIR_TARGET} \
+ --with-build-sysroot=${STAGING_DIR_TARGET}"
+
+
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"