summaryrefslogtreecommitdiff
path: root/openembedded/packages/rxvt/rxvt_2.7.9.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-08-31 18:07:55 +0000
committerRichard Purdie <richard@openedhand.com>2005-08-31 18:07:55 +0000
commit9ed0d2aa99a76a864d4793f54146c0e79e373712 (patch)
treebf6b07b0cfcc23ebb23130013e348ff84f38ce32 /openembedded/packages/rxvt/rxvt_2.7.9.bb
parent047f13b69a6907483a4cf71cf20c8434e20c8873 (diff)
downloadopenembedded-core-9ed0d2aa99a76a864d4793f54146c0e79e373712.tar.gz
openembedded-core-9ed0d2aa99a76a864d4793f54146c0e79e373712.tar.bz2
openembedded-core-9ed0d2aa99a76a864d4793f54146c0e79e373712.tar.xz
openembedded-core-9ed0d2aa99a76a864d4793f54146c0e79e373712.zip
Add some extra packages to the image
git-svn-id: https://svn.o-hand.com/repos/poky@10 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/rxvt/rxvt_2.7.9.bb')
-rw-r--r--openembedded/packages/rxvt/rxvt_2.7.9.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/openembedded/packages/rxvt/rxvt_2.7.9.bb b/openembedded/packages/rxvt/rxvt_2.7.9.bb
new file mode 100644
index 000000000..c201d16f8
--- /dev/null
+++ b/openembedded/packages/rxvt/rxvt_2.7.9.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Well known terminal emulator"
+SECTION = "x11/utils"
+PR = "r1"
+DEPENDS = "x11 libxft"
+LICENSE = "GPL"
+SRC_URI = "${HANDHELDS_CVS};module=apps/rxvt \
+ file://include.patch;patch=1"
+
+inherit autotools update-alternatives
+
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt-2.7.9"
+
+S = ${WORKDIR}/rxvt
+
+EXTRA_OECONF = "--disable-menubar --disable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --with-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu,jp \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-plain-scroll \
+ --enable-combining --enable-shared \
+ --with-x=${STAGING_LIBDIR}/.."
+
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11 -lXft'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+ echo '#define HAVE_UTMP_H 1' >> config.h
+ echo '#define HAVE_TTYSLOT 1' >> config.h
+}