summaryrefslogtreecommitdiff
path: root/bitbake-dev/lib/bb/command.py
diff options
context:
space:
mode:
Diffstat (limited to 'bitbake-dev/lib/bb/command.py')
-rw-r--r--bitbake-dev/lib/bb/command.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/bitbake-dev/lib/bb/command.py b/bitbake-dev/lib/bb/command.py
index 9226a2772..e7c3770ff 100644
--- a/bitbake-dev/lib/bb/command.py
+++ b/bitbake-dev/lib/bb/command.py
@@ -233,6 +233,14 @@ class CommandsAsync:
command.finishAsyncCommand()
parseFiles.needcache = True
+ def compareRevisions(self, command, params):
+ """
+ Parse the .bb files
+ """
+ command.cooker.compareRevisions()
+ command.finishAsyncCommand()
+ compareRevisions.needcache = True
+
#
# Events
#
@@ -251,3 +259,14 @@ class CookerCommandFailed(bb.event.Event):
def __init__(self, data, error):
bb.event.Event.__init__(self, data)
self.error = error
+
+class CookerCommandSetExitCode(bb.event.Event):
+ """
+ Set the exit code for a cooker command
+ """
+ def __init__(self, data, exitcode):
+ bb.event.Event.__init__(self, data)
+ self.exitcode = int(exitcode)
+
+
+