summaryrefslogtreecommitdiff
path: root/meta-trygvis
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2012-05-11 11:30:22 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2012-05-11 11:30:22 +0200
commit5a93d5c34e2688b70434ecc3d5ea5e1423043dc8 (patch)
tree2b8dd5160773659ef17b3d2dcf057e3ea318fd22 /meta-trygvis
parentde8ddb00cbf32ef72d959a1d2e8bf8a38c802c56 (diff)
downloadopenembedded-olinuxino-trygvis-5a93d5c34e2688b70434ecc3d5ea5e1423043dc8.tar.gz
openembedded-olinuxino-trygvis-5a93d5c34e2688b70434ecc3d5ea5e1423043dc8.tar.bz2
openembedded-olinuxino-trygvis-5a93d5c34e2688b70434ecc3d5ea5e1423043dc8.tar.xz
openembedded-olinuxino-trygvis-5a93d5c34e2688b70434ecc3d5ea5e1423043dc8.zip
o Initial import of my own OpenEmbedded distribution.
Diffstat (limited to 'meta-trygvis')
-rw-r--r--meta-trygvis/conf/layer.conf10
-rw-r--r--meta-trygvis/recipes-core/images/trygvis-bare.bb12
-rw-r--r--meta-trygvis/recipes-core/images/trygvis-console.bb22
-rw-r--r--meta-trygvis/recipes-core/netbase/files/olinuxino/interfaces15
-rw-r--r--meta-trygvis/recipes-core/netbase/netbase_4.47.bbappend1
5 files changed, 60 insertions, 0 deletions
diff --git a/meta-trygvis/conf/layer.conf b/meta-trygvis/conf/layer.conf
new file mode 100644
index 0000000..1d163e5
--- /dev/null
+++ b/meta-trygvis/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH := "${BBPATH}:${LAYERDIR}"
+
+# We have a packages directory, add to BBFILES
+BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "trygvis"
+BBFILE_PATTERN_trygvis := "^${LAYERDIR}/"
+BBFILE_PRIORITY_trygvis = "6"
diff --git a/meta-trygvis/recipes-core/images/trygvis-bare.bb b/meta-trygvis/recipes-core/images/trygvis-bare.bb
new file mode 100644
index 0000000..54ffdc5
--- /dev/null
+++ b/meta-trygvis/recipes-core/images/trygvis-bare.bb
@@ -0,0 +1,12 @@
+require recipes-core/images/core-image-minimal.bb
+
+DESCRIPTION = "Trygvis, yeah."
+
+PR = "r1"
+
+# IMAGE_FEATURES += "apps-console-core"
+
+# fsck.ext2
+IMAGE_INSTALL += "e2fsprogs"
+
+export IMAGE_BASENAME = "trygvis"
diff --git a/meta-trygvis/recipes-core/images/trygvis-console.bb b/meta-trygvis/recipes-core/images/trygvis-console.bb
new file mode 100644
index 0000000..c663304
--- /dev/null
+++ b/meta-trygvis/recipes-core/images/trygvis-console.bb
@@ -0,0 +1,22 @@
+require trygvis-bare.bb
+
+DESCRIPTION += "Console version."
+
+PR = "r1"
+
+IMAGE_FEATURES += "apps-console-core"
+IMAGE_FEATURES += "tools-sdk"
+IMAGE_FEATURES += "tools-debug"
+IMAGE_FEATURES += "tools-profile"
+IMAGE_FEATURES += "tools-testapps"
+IMAGE_FEATURES += "ssh-server-dropbear"
+IMAGE_FEATURES += "debug-tweaks"
+# IMAGE_FEATURES += "${X11_IMAGE_FEATURES}"
+
+IMAGE_INSTALL += "alsa-utils alsa-tools"
+
+IMAGE_INSTALL += "dhcp"
+
+IMAGE_INSTALL += "bluez-hcidump bluez4"
+
+export IMAGE_BASENAME = "trygvis"
diff --git a/meta-trygvis/recipes-core/netbase/files/olinuxino/interfaces b/meta-trygvis/recipes-core/netbase/files/olinuxino/interfaces
new file mode 100644
index 0000000..adffef9
--- /dev/null
+++ b/meta-trygvis/recipes-core/netbase/files/olinuxino/interfaces
@@ -0,0 +1,15 @@
+# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
+
+# The loopback interface
+auto lo
+iface lo inet loopback
+
+# Wireless interfaces
+iface wlan0 inet dhcp
+ wireless_mode managed
+ wireless_essid any
+ wpa-driver wext
+ wpa-conf /etc/wpa_supplicant.conf
+
+auto usb0
+iface usb0 inet dhcp
diff --git a/meta-trygvis/recipes-core/netbase/netbase_4.47.bbappend b/meta-trygvis/recipes-core/netbase/netbase_4.47.bbappend
new file mode 100644
index 0000000..81fe7b7
--- /dev/null
+++ b/meta-trygvis/recipes-core/netbase/netbase_4.47.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"