aboutsummaryrefslogtreecommitdiff
path: root/apps/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2015-02-22 16:16:48 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2015-02-22 16:16:48 +0100
commitd0fb1850606ce003887259675e271a9aade4fda0 (patch)
tree0bf3be59348c0fd64f17c9e9a727e85ffc7bd98b /apps/CMakeLists.txt
parentba6324930118a62e05d3869f99543c4a7507f105 (diff)
downloadble-toys-d0fb1850606ce003887259675e271a9aade4fda0.tar.gz
ble-toys-d0fb1850606ce003887259675e271a9aade4fda0.tar.bz2
ble-toys-d0fb1850606ce003887259675e271a9aade4fda0.tar.xz
ble-toys-d0fb1850606ce003887259675e271a9aade4fda0.zip
o Starting a new class for all SoilMoisture GATT stuff.
Diffstat (limited to 'apps/CMakeLists.txt')
-rw-r--r--apps/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
index aefb0fb..e210716 100644
--- a/apps/CMakeLists.txt
+++ b/apps/CMakeLists.txt
@@ -1,4 +1,5 @@
set(APPS sm-get-value ble-inspect-device)
+set(shared_sources SoilMoisture.cpp)
# Boost
find_package(Boost COMPONENTS system log thread REQUIRED)
@@ -12,7 +13,7 @@ find_package(Threads REQUIRED)
foreach(app ${APPS})
include_directories("${PROJECT_SOURCE_DIR}/include")
- add_executable(${app} ${app}.cpp)
+ add_executable(${app} ${app}.cpp ${shared_sources})
add_dependencies(${app} ble)
target_link_libraries(${app} ble)