aboutsummaryrefslogtreecommitdiff
path: root/sensor/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2015-03-22 17:29:35 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2015-03-22 17:29:35 +0100
commitd7d545575250f616f0b9e2243e08544ab2794a03 (patch)
tree3ac666251499b8b665d82681920f1afee645cb51 /sensor/CMakeLists.txt
parentaad1eaa291460509a5cf94092609ae22ebef5494 (diff)
downloadble-toys-d7d545575250f616f0b9e2243e08544ab2794a03.tar.gz
ble-toys-d7d545575250f616f0b9e2243e08544ab2794a03.tar.bz2
ble-toys-d7d545575250f616f0b9e2243e08544ab2794a03.tar.xz
ble-toys-d7d545575250f616f0b9e2243e08544ab2794a03.zip
o Renaming trygvis::soil_moisture to trygvis::sample.
Diffstat (limited to 'sensor/CMakeLists.txt')
-rw-r--r--sensor/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/sensor/CMakeLists.txt b/sensor/CMakeLists.txt
index 5d7612f..7cee42b 100644
--- a/sensor/CMakeLists.txt
+++ b/sensor/CMakeLists.txt
@@ -1,5 +1,8 @@
+file(GLOB INCLUDES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} include/*.h)
+
add_library(trygvis-sensor
- main/SensorSample.cpp)
+ main/SensorSample.cpp
+ ${INCLUDES})
include_directories("${PROJECT_SOURCE_DIR}/json/src")
include_directories(include)