aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2017-01-25 22:24:18 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2017-01-25 22:29:25 +0100
commit40e04e3772726829d66c12e69f24b03920d79c67 (patch)
tree636811bad956798c9d5d22de9e7ba8c799b8d791 /CMakeLists.txt
parent2fff65aed2477a503c72629d27e2a330d30c02d1 (diff)
downloadstm32f103-playground-40e04e3772726829d66c12e69f24b03920d79c67.tar.gz
stm32f103-playground-40e04e3772726829d66c12e69f24b03920d79c67.tar.bz2
stm32f103-playground-40e04e3772726829d66c12e69f24b03920d79c67.tar.xz
stm32f103-playground-40e04e3772726829d66c12e69f24b03920d79c67.zip
o Moving tinyprintf and stm libraries under thirdparty.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fbc73aa..e66b70e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,13 +32,13 @@ function(add_extra_commands target_name)
endfunction()
# https://github.com/cjlano/tinyprintf
-add_library(tinyprintf STATIC tinyprintf/tinyprintf.c tinyprintf/tinyprintf.h)
-target_include_directories(tinyprintf PUBLIC tinyprintf)
+add_library(tinyprintf STATIC thirdparty/tinyprintf/tinyprintf.c thirdparty/tinyprintf/tinyprintf.h)
+target_include_directories(tinyprintf PUBLIC thirdparty/tinyprintf)
-set(STM32F10X_STDPERIPH_LIB ${CMAKE_SOURCE_DIR}/tmp/STM32F10x_StdPeriph_Lib_V3.5.0)
+set(STM32F10X_STDPERIPH_LIB ${CMAKE_SOURCE_DIR}/thirdparty/STM32F10x_StdPeriph_Lib_V3.5.0)
set(STM32F10X_STDPERIPH_DEFINES STM32F10X_MD USE_STDPERIPH_DRIVER)
set(PLAYGROUND_DIR ${CMAKE_SOURCE_DIR}/playground)
-set(TINYPRINTF_DIR ${CMAKE_SOURCE_DIR}/tinyprintf)
+set(TINYPRINTF_DIR ${CMAKE_SOURCE_DIR}/thirdparty/tinyprintf)
add_library(playground OBJECT
playground/src/init_low.s playground/src/init_high.cpp
@@ -52,7 +52,7 @@ add_library(playground OBJECT
playground/include/debug.h)
target_include_directories(playground PUBLIC
playground/include
- tinyprintf
+ thirdparty/tinyprintf
${STM32F10X_STDPERIPH_LIB}/Libraries/CMSIS/CM3/CoreSupport
${STM32F10X_STDPERIPH_LIB}/Libraries/CMSIS/CM3/DeviceSupport/ST/STM32F10x
${STM32F10X_STDPERIPH_LIB}/Libraries/STM32F10x_StdPeriph_Driver/inc