aboutsummaryrefslogtreecommitdiff
path: root/apps/cpp1/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2017-01-25 22:33:54 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2017-01-25 22:33:54 +0100
commit99faf57b4296b032e486cbf3829745cbcb14a80b (patch)
tree85ad7541a4e7aef2a5ffa9eef91b3b26100ed2f8 /apps/cpp1/CMakeLists.txt
parent40e04e3772726829d66c12e69f24b03920d79c67 (diff)
downloadstm32f103-playground-master.tar.gz
stm32f103-playground-master.tar.bz2
stm32f103-playground-master.tar.xz
stm32f103-playground-master.zip
o Using upstream's tinyprintf which requires 64-bit math operations, so add gcc as a required library.HEADmaster
Diffstat (limited to 'apps/cpp1/CMakeLists.txt')
-rw-r--r--apps/cpp1/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/apps/cpp1/CMakeLists.txt b/apps/cpp1/CMakeLists.txt
index 2580535..381fd73 100644
--- a/apps/cpp1/CMakeLists.txt
+++ b/apps/cpp1/CMakeLists.txt
@@ -13,7 +13,7 @@ target_include_directories(cpp1.elf PUBLIC
$<TARGET_PROPERTY:playground,INTERFACE_INCLUDE_DIRECTORIES>
)
target_compile_definitions(cpp1.elf PUBLIC ${STM32F10X_STDPERIPH_DEFINES})
-target_link_libraries(cpp1.elf tinyprintf)
+target_link_libraries(cpp1.elf tinyprintf gcc)
set_target_properties(cpp1.elf PROPERTIES LINK_FLAGS "-nostartfiles -T${CMAKE_SOURCE_DIR}/cmake/stm32.ld")
add_extra_commands(cpp1.elf)