aboutsummaryrefslogtreecommitdiff
path: root/apps/cpp1/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'apps/cpp1/CMakeLists.txt')
-rw-r--r--apps/cpp1/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/apps/cpp1/CMakeLists.txt b/apps/cpp1/CMakeLists.txt
index 2580535..381fd73 100644
--- a/apps/cpp1/CMakeLists.txt
+++ b/apps/cpp1/CMakeLists.txt
@@ -13,7 +13,7 @@ target_include_directories(cpp1.elf PUBLIC
$<TARGET_PROPERTY:playground,INTERFACE_INCLUDE_DIRECTORIES>
)
target_compile_definitions(cpp1.elf PUBLIC ${STM32F10X_STDPERIPH_DEFINES})
-target_link_libraries(cpp1.elf tinyprintf)
+target_link_libraries(cpp1.elf tinyprintf gcc)
set_target_properties(cpp1.elf PROPERTIES LINK_FLAGS "-nostartfiles -T${CMAKE_SOURCE_DIR}/cmake/stm32.ld")
add_extra_commands(cpp1.elf)