aboutsummaryrefslogtreecommitdiff
path: root/apps/i2c1/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2017-01-25 22:33:54 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2017-01-25 22:33:54 +0100
commit99faf57b4296b032e486cbf3829745cbcb14a80b (patch)
tree85ad7541a4e7aef2a5ffa9eef91b3b26100ed2f8 /apps/i2c1/CMakeLists.txt
parent40e04e3772726829d66c12e69f24b03920d79c67 (diff)
downloadstm32f103-playground-master.tar.gz
stm32f103-playground-master.tar.bz2
stm32f103-playground-master.tar.xz
stm32f103-playground-master.zip
o Using upstream's tinyprintf which requires 64-bit math operations, so add gcc as a required library.HEADmaster
Diffstat (limited to 'apps/i2c1/CMakeLists.txt')
-rw-r--r--apps/i2c1/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/apps/i2c1/CMakeLists.txt b/apps/i2c1/CMakeLists.txt
index 67139f8..e148c41 100644
--- a/apps/i2c1/CMakeLists.txt
+++ b/apps/i2c1/CMakeLists.txt
@@ -20,6 +20,8 @@ target_include_directories(i2c1.elf PUBLIC
${STM32F10X_STDPERIPH_LIB}/Libraries/STM32F10x_StdPeriph_Driver/inc)
target_compile_definitions(i2c1.elf PUBLIC ${STM32F10X_STDPERIPH_DEFINES} USE_FULL_ASSERT)
+target_link_libraries(i2c1.elf gcc)
+
set_target_properties(i2c1.elf PROPERTIES O_LEVEL 3)
#set_source_files_properties(i2c1.cpp PROPERTIES O_LEVEL s)