aboutsummaryrefslogtreecommitdiff
path: root/apps/i2c1/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'apps/i2c1/CMakeLists.txt')
-rw-r--r--apps/i2c1/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/apps/i2c1/CMakeLists.txt b/apps/i2c1/CMakeLists.txt
index 67139f8..e148c41 100644
--- a/apps/i2c1/CMakeLists.txt
+++ b/apps/i2c1/CMakeLists.txt
@@ -20,6 +20,8 @@ target_include_directories(i2c1.elf PUBLIC
${STM32F10X_STDPERIPH_LIB}/Libraries/STM32F10x_StdPeriph_Driver/inc)
target_compile_definitions(i2c1.elf PUBLIC ${STM32F10X_STDPERIPH_DEFINES} USE_FULL_ASSERT)
+target_link_libraries(i2c1.elf gcc)
+
set_target_properties(i2c1.elf PROPERTIES O_LEVEL 3)
#set_source_files_properties(i2c1.cpp PROPERTIES O_LEVEL s)