aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2016-07-16 22:59:28 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2016-07-16 22:59:28 +0200
commit62e8183d33ae159b9e984d2ef5b4a83656d56a16 (patch)
tree49eda06698ad2a11ad661386e6b1524a4ec11aba /CMakeLists.txt
parent4675ec55f6bdb8f826cc94a9585ff9229c277983 (diff)
downloadelfinfo-62e8183d33ae159b9e984d2ef5b4a83656d56a16.tar.gz
elfinfo-62e8183d33ae159b9e984d2ef5b4a83656d56a16.tar.bz2
elfinfo-62e8183d33ae159b9e984d2ef5b4a83656d56a16.tar.xz
elfinfo-62e8183d33ae159b9e984d2ef5b4a83656d56a16.zip
o Working version that can take the data from the LD script. Only tested with the Intel Quark D2000 LD script.
lexer: Allowing capital X in hex numbers too.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2749ba8..ddbe243 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,9 +7,10 @@ find_package(Antlr4)
antlr4_add_target(TARGET GnuLd STATIC LEXER GnuLdLexer.g4 PARSER GnuLdParser.g4)
-add_executable(elfinfo elfinfo.cpp ld.cpp ld.h)
+add_executable(elfinfo elfinfo.cpp Ld.cpp includes/trygvis/elfinfo/Ld.h)
target_compile_options(elfinfo PUBLIC "--std=c++14")
target_link_libraries(elfinfo elf GnuLd Antlr4::antlr4_shared)
+target_include_directories(elfinfo PUBLIC includes/trygvis/elfinfo)
INSTALL(TARGETS elfinfo
RUNTIME DESTINATION bin