aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2749ba8..ddbe243 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,9 +7,10 @@ find_package(Antlr4)
antlr4_add_target(TARGET GnuLd STATIC LEXER GnuLdLexer.g4 PARSER GnuLdParser.g4)
-add_executable(elfinfo elfinfo.cpp ld.cpp ld.h)
+add_executable(elfinfo elfinfo.cpp Ld.cpp includes/trygvis/elfinfo/Ld.h)
target_compile_options(elfinfo PUBLIC "--std=c++14")
target_link_libraries(elfinfo elf GnuLd Antlr4::antlr4_shared)
+target_include_directories(elfinfo PUBLIC includes/trygvis/elfinfo)
INSTALL(TARGETS elfinfo
RUNTIME DESTINATION bin